summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/orbited/orbited-0.7.10-r1.ebuild')
-rw-r--r--net-misc/orbited/orbited-0.7.10-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-misc/orbited/orbited-0.7.10-r1.ebuild b/net-misc/orbited/orbited-0.7.10-r1.ebuild
new file mode 100644
index 000000000000..26ca05dc1e3c
--- /dev/null
+++ b/net-misc/orbited/orbited-0.7.10-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+PYTHON_DEPEND="2"
+
+inherit distutils
+
+DESCRIPTION="Real-time communication for the browser"
+HOMEPAGE="http://orbited.org"
+SRC_URI="mirror://pypi/o/${PN}/${P}.tar.gz"
+
+LICENSE="MIT GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="dev-python/demjson
+ >=dev-python/morbid-0.8.4
+ dev-python/stomper
+ dev-python/twisted-core
+ dev-python/twisted-web"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_install() {
+ distutils_src_install
+ insinto /etc
+ doins "${FILESDIR}/orbited.cfg" || die
+ newinitd "${FILESDIR}/orbited.init" orbited || die
+}