summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/proxytunnel/proxytunnel-1.9.1-r1.ebuild')
-rw-r--r--net-misc/proxytunnel/proxytunnel-1.9.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/proxytunnel/proxytunnel-1.9.1-r1.ebuild b/net-misc/proxytunnel/proxytunnel-1.9.1-r1.ebuild
new file mode 100644
index 000000000000..d6d546ccf2f4
--- /dev/null
+++ b/net-misc/proxytunnel/proxytunnel-1.9.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Connect stdin and stdout to a server somewhere on the network, through a standard HTTPS proxy"
+HOMEPAGE="https://github.com/proxytunnel/proxytunnel/ http://proxytunnel.sourceforge.net/"
+SRC_URI="https://github.com/proxytunnel/proxytunnel/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="static"
+
+RDEPEND="dev-libs/openssl:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ app-text/asciidoc
+ app-text/xmlto
+ "
+
+src_prepare() {
+ sed -i -e 's/libssl/libssl libcrypto/' Makefile || die "Sed failed!"
+ epatch "${FILESDIR}"/${PN}-allowTLS.patch
+}
+
+src_compile() {
+ use static && append-ldflags -static
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake install prefix="${EPREFIX}"/usr DESTDIR="${D}" || die
+ dodoc CHANGES CREDITS INSTALL KNOWN_ISSUES LICENSE.txt README RELNOTES TODO
+}