summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/putty/putty-0.64.ebuild')
-rw-r--r--net-misc/putty/putty-0.64.ebuild88
1 files changed, 88 insertions, 0 deletions
diff --git a/net-misc/putty/putty-0.64.ebuild b/net-misc/putty/putty-0.64.ebuild
new file mode 100644
index 000000000000..3859b9bcb258
--- /dev/null
+++ b/net-misc/putty/putty-0.64.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils gnome2-utils toolchain-funcs
+
+DESCRIPTION="A Free Telnet/SSH Client"
+HOMEPAGE="http://www.chiark.greenend.org.uk/~sgtatham/putty/"
+LICENSE="MIT"
+
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ppc ~ppc64 sparc x86"
+IUSE="doc +gtk ipv6 kerberos"
+SRC_URI="
+ http://dev.gentoo.org/~jer/${PN}-icons.tar.bz2
+ http://the.earth.li/~sgtatham/${PN}/latest/${P}.tar.gz
+"
+
+RDEPEND="
+ !net-misc/pssh
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/pango
+ )
+ kerberos? ( virtual/krb5 )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ sed -i \
+ -e '/AM_PATH_GTK(/d' \
+ -e 's|-Werror||g' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ cd "${S}"/unix || die
+ econf \
+ $(use_with kerberos gssapi) \
+ $(use_with gtk)
+}
+
+src_compile() {
+ cd "${S}"/unix || die
+ emake AR=$(tc-getAR) $(usex ipv6 '' COMPAT=-DNO_IPV6)
+}
+
+src_install() {
+ dodoc doc/puttydoc.txt
+
+ if use doc; then
+ dohtml doc/*.html
+ fi
+
+ cd "${S}"/unix || die
+ default
+
+ if use gtk ; then
+ for i in 16 22 24 32 48 64 128 256; do
+ newicon -s ${i} "${WORKDIR}"/${PN}-icons/${PN}-${i}.png ${PN}.png
+ done
+
+ # install desktop file provided by Gustav Schaffter in #49577
+ make_desktop_entry ${PN} PuTTY ${PN} Network
+ fi
+}
+
+pkg_preinst() {
+ use gtk && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use gtk && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && gnome2_icon_cache_update
+}