summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/giftcurs')
-rw-r--r--net-p2p/giftcurs/Manifest1
-rw-r--r--net-p2p/giftcurs/giftcurs-0.6.2.ebuild37
-rw-r--r--net-p2p/giftcurs/metadata.xml5
3 files changed, 43 insertions, 0 deletions
diff --git a/net-p2p/giftcurs/Manifest b/net-p2p/giftcurs/Manifest
new file mode 100644
index 000000000000..372d55fa5990
--- /dev/null
+++ b/net-p2p/giftcurs/Manifest
@@ -0,0 +1 @@
+DIST giFTcurs-0.6.2.tar.gz 455055 SHA256 80db72ac16463ce084e76dc9aaae5b54ce8db085610c98fe2975c5b8f51a598d
diff --git a/net-p2p/giftcurs/giftcurs-0.6.2.ebuild b/net-p2p/giftcurs/giftcurs-0.6.2.ebuild
new file mode 100644
index 000000000000..b799aa5db91e
--- /dev/null
+++ b/net-p2p/giftcurs/giftcurs-0.6.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_P="giFTcurs-${PV}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="A ncurses frontend to the giFT daemon"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${MY_P}.tar.gz"
+HOMEPAGE="http://www.nongnu.org/giftcurs/"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="gpm nls unicode"
+KEYWORDS="alpha amd64 ~ia64 ~ppc sparc x86 ~x86-fbsd"
+
+RDEPEND="
+ >=sys-libs/ncurses-5.2
+ >=dev-libs/glib-2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_compile() {
+ local myconf=""
+
+ use gpm || myconf="${myconf} --disable-mouse --disable-libgpm"
+ use nls || myconf="${myconf} --disable-nls"
+ use unicode && myconf="${myconf} --with-ncursesw"
+
+ econf $myconf || die "./configure failed"
+
+ emake || die "Compilation failed"
+}
+
+src_install() {
+ einstall || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}
diff --git a/net-p2p/giftcurs/metadata.xml b/net-p2p/giftcurs/metadata.xml
new file mode 100644
index 000000000000..aa0f3664825f
--- /dev/null
+++ b/net-p2p/giftcurs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>net-p2p</herd>
+</pkgmetadata>