summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/sshuttle/sshuttle-1.0.5.ebuild')
-rw-r--r--net-proxy/sshuttle/sshuttle-1.0.5.ebuild14
1 files changed, 11 insertions, 3 deletions
diff --git a/net-proxy/sshuttle/sshuttle-1.0.5.ebuild b/net-proxy/sshuttle/sshuttle-1.0.5.ebuild
index 888000fa91a9..5cc44739a206 100644
--- a/net-proxy/sshuttle/sshuttle-1.0.5.ebuild
+++ b/net-proxy/sshuttle/sshuttle-1.0.5.ebuild
@@ -32,10 +32,10 @@ CONFIG_CHECK="~NETFILTER_XT_TARGET_HL ~IP_NF_TARGET_REDIRECT ~IP_NF_MATCH_TTL ~N
distutils_enable_tests pytest
python_prepare_all() {
- # don't run tests via setup.py pytest
+ # Don't run tests via setup.py pytest
sed -i "/setup_requires=/s/'pytest-runner'//" setup.py || die
- # don't require pytest-cov when running tests
+ # Don't require pytest-cov when running tests
sed -i "s/^addopts =/#\0/" setup.cfg || die
distutils-r1_python_prepare_all
@@ -47,6 +47,14 @@ python_compile_all() {
python_install_all() {
HTML_DOCS=( docs/_build/html/. )
- doman docs/_build/man/*
+
+ # Sphinx 4.0 changed the layout for installed man pages
+ # https://bugs.gentoo.org/789417
+ if has_version '>=dev-python/sphinx-4.0.0' ; then
+ doman docs/_build/man/1/*
+ else
+ doman docs/_build/man/*
+ fi
+
distutils-r1_python_install_all
}