summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/crackle')
-rw-r--r--net-wireless/crackle/crackle-9999.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-wireless/crackle/crackle-9999.ebuild b/net-wireless/crackle/crackle-9999.ebuild
new file mode 100644
index 000000000000..65b8d939410c
--- /dev/null
+++ b/net-wireless/crackle/crackle-9999.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Crackle cracks BLE Encryption (AKA Bluetooth Smart)"
+HOMEPAGE="http://lacklustre.net/projects/crackle/"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/mikeryan/crackle.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="http://lacklustre.net/projects/crackle/${P}.tgz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}
+ test? ( dev-lang/perl )"
+
+src_install() {
+ DESTDIR="${ED}" PREFIX=/usr emake install
+}