summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/madwifi-ng/files')
-rw-r--r--net-wireless/madwifi-ng/files/madwifi-dfs-ieee80211-skb-update.patch12
-rw-r--r--net-wireless/madwifi-ng/files/madwifi-ng-0.9.3-uudecode-gcda-fix.patch12
-rw-r--r--net-wireless/madwifi-ng/files/madwifi-ng-0.9.4-2.6.27-r3811.patch190
-rw-r--r--net-wireless/madwifi-ng/files/madwifi-ng-0.9.4-request_module-build.patch31
-rw-r--r--net-wireless/madwifi-ng/files/madwifi-ng-injection-r3925.patch32
-rw-r--r--net-wireless/madwifi-ng/files/madwifi-ng-r1886.patch26
6 files changed, 0 insertions, 303 deletions
diff --git a/net-wireless/madwifi-ng/files/madwifi-dfs-ieee80211-skb-update.patch b/net-wireless/madwifi-ng/files/madwifi-dfs-ieee80211-skb-update.patch
deleted file mode 100644
index af14023b8c7c..000000000000
--- a/net-wireless/madwifi-ng/files/madwifi-dfs-ieee80211-skb-update.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- a/net80211/ieee80211_linux.h 2008-05-09 01:15:01 +0400
-+++ b/net80211/ieee80211_linux.h 2008-05-11 02:26:35 +0400
-@@ -315,6 +315,9 @@ typedef spinlock_t acl_lock_t;
- #if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,14)
- #define __skb_append(a,b,c) __skb_append(a, b)
- #endif
-+#if LINUX_VERSION_CODE > KERNEL_VERSION(2,6,25)
-+#define __skb_append(a,b,c) __skb_queue_after(c,a,b)
-+#endif
-
- /*
- * Per-node power-save queue definitions. Beware of control
diff --git a/net-wireless/madwifi-ng/files/madwifi-ng-0.9.3-uudecode-gcda-fix.patch b/net-wireless/madwifi-ng/files/madwifi-ng-0.9.3-uudecode-gcda-fix.patch
deleted file mode 100644
index 686958cc1399..000000000000
--- a/net-wireless/madwifi-ng/files/madwifi-ng-0.9.3-uudecode-gcda-fix.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-Index: ath_hal/Makefile
-===================================================================
---- ath_hal/Makefile (revision 1648)
-+++ ath_hal/Makefile (working copy)
-@@ -61,6 +61,7 @@
- ath_hal-objs := ah_osdep.o ${TARGET}.hal.o
-
- hostprogs-y := uudecode
-+uudecode-objs := uudecode.o
-
- # For older 2.6 kernels
- host-progs := $(hostprogs-y)
diff --git a/net-wireless/madwifi-ng/files/madwifi-ng-0.9.4-2.6.27-r3811.patch b/net-wireless/madwifi-ng/files/madwifi-ng-0.9.4-2.6.27-r3811.patch
deleted file mode 100644
index b02795f5f76a..000000000000
--- a/net-wireless/madwifi-ng/files/madwifi-ng-0.9.4-2.6.27-r3811.patch
+++ /dev/null
@@ -1,190 +0,0 @@
-=== modified file 'net80211/ieee80211_wireless.c'
---- net80211/ieee80211_wireless.c 2008-10-22 18:13:35 +0000
-+++ net80211/ieee80211_wireless.c 2008-10-22 18:13:41 +0000
-@@ -1551,11 +1551,19 @@
-
- struct iwscanreq { /* XXX: right place for this declaration? */
- struct ieee80211vap *vap;
-+ struct iw_request_info *info;
- char *current_ev;
- char *end_buf;
- int mode;
- };
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 27) && !defined(IW_REQUEST_FLAG_COMPAT)
-+#define iwe_stream_add_event(a, b, c, d, e) iwe_stream_add_event(b, c, d, e)
-+#define iwe_stream_add_point(a, b, c, d, e) iwe_stream_add_point(b, c, d, e)
-+#define iwe_stream_add_value(a, b, c, d, e, f) \
-+ iwe_stream_add_value(b, c, d, e, f)
-+#define iwe_stream_lcp_len(a) IW_EV_LCP_LEN
-+#endif
- static int
- giwscan_cb(void *arg, const struct ieee80211_scan_entry *se)
- {
-@@ -1590,7 +1598,8 @@
- IEEE80211_ADDR_COPY(iwe.u.ap_addr.sa_data, se->se_macaddr);
- else
- IEEE80211_ADDR_COPY(iwe.u.ap_addr.sa_data, se->se_bssid);
-- current_ev = iwe_stream_add_event(current_ev, end_buf, &iwe, IW_EV_ADDR_LEN);
-+ current_ev = iwe_stream_add_event(req->info, current_ev, end_buf,
-+ &iwe, IW_EV_ADDR_LEN);
-
- /* We ran out of space in the buffer. */
- if (last_ev == current_ev)
-@@ -1603,11 +1612,11 @@
- if (vap->iv_opmode == IEEE80211_M_HOSTAP) {
- iwe.u.data.length = vap->iv_des_nssid > 0 ?
- vap->iv_des_ssid[0].len : 0;
-- current_ev = iwe_stream_add_point(current_ev,
-+ current_ev = iwe_stream_add_point(req->info, current_ev,
- end_buf, &iwe, vap->iv_des_ssid[0].ssid);
- } else {
- iwe.u.data.length = se->se_ssid[1];
-- current_ev = iwe_stream_add_point(current_ev,
-+ current_ev = iwe_stream_add_point(req->info, current_ev,
- end_buf, &iwe, (char *) se->se_ssid+2);
- }
-
-@@ -1621,8 +1630,8 @@
- iwe.cmd = SIOCGIWMODE;
- iwe.u.mode = se->se_capinfo & IEEE80211_CAPINFO_ESS ?
- IW_MODE_MASTER : IW_MODE_ADHOC;
-- current_ev = iwe_stream_add_event(current_ev,
-- end_buf, &iwe, IW_EV_UINT_LEN);
-+ current_ev = iwe_stream_add_event(req->info, current_ev,
-+ end_buf, &iwe, IW_EV_UINT_LEN);
-
- /* We ran out of space in the buffer. */
- if (last_ev == current_ev)
-@@ -1634,8 +1643,8 @@
- iwe.cmd = SIOCGIWFREQ;
- iwe.u.freq.m = se->se_chan->ic_freq * 100000;
- iwe.u.freq.e = 1;
-- current_ev = iwe_stream_add_event(current_ev,
-- end_buf, &iwe, IW_EV_FREQ_LEN);
-+ current_ev = iwe_stream_add_event(req->info, current_ev,
-+ end_buf, &iwe, IW_EV_FREQ_LEN);
-
- /* We ran out of space in the buffer. */
- if (last_ev == current_ev)
-@@ -1645,8 +1654,8 @@
- last_ev = current_ev;
- iwe.cmd = IWEVQUAL;
- set_quality(&iwe.u.qual, se->se_rssi, ATH_DEFAULT_NOISE);
-- current_ev = iwe_stream_add_event(current_ev,
-- end_buf, &iwe, IW_EV_QUAL_LEN);
-+ current_ev = iwe_stream_add_event(req->info, current_ev,
-+ end_buf, &iwe, IW_EV_QUAL_LEN);
-
- /* We ran out of space in the buffer */
- if (last_ev == current_ev)
-@@ -1660,7 +1669,8 @@
- else
- iwe.u.data.flags = IW_ENCODE_DISABLED;
- iwe.u.data.length = 0;
-- current_ev = iwe_stream_add_point(current_ev, end_buf, &iwe, "");
-+ current_ev = iwe_stream_add_point(req->info, current_ev,
-+ end_buf, &iwe, "");
-
- /* We ran out of space in the buffer. */
- if (last_ev == current_ev)
-@@ -1669,28 +1679,28 @@
- memset(&iwe, 0, sizeof(iwe));
- last_ev = current_ev;
- iwe.cmd = SIOCGIWRATE;
-- current_val = current_ev + IW_EV_LCP_LEN;
-+ current_val = current_ev + iwe_stream_lcp_len(req->info);
- /* NB: not sorted, does it matter? */
- for (j = 0; j < se->se_rates[1]; j++) {
- int r = se->se_rates[2 + j] & IEEE80211_RATE_VAL;
- if (r != 0) {
- iwe.u.bitrate.value = r * (1000000 / 2);
-- current_val = iwe_stream_add_value(current_ev,
-- current_val, end_buf, &iwe,
-- IW_EV_PARAM_LEN);
-+ current_val = iwe_stream_add_value(req->info,
-+ current_ev, current_val, end_buf,
-+ &iwe, IW_EV_PARAM_LEN);
- }
- }
- for (j = 0; j < se->se_xrates[1]; j++) {
- int r = se->se_xrates[2+j] & IEEE80211_RATE_VAL;
- if (r != 0) {
- iwe.u.bitrate.value = r * (1000000 / 2);
-- current_val = iwe_stream_add_value(current_ev,
-- current_val, end_buf, &iwe,
-- IW_EV_PARAM_LEN);
-+ current_val = iwe_stream_add_value(req->info,
-+ current_ev, current_val, end_buf,
-+ &iwe, IW_EV_PARAM_LEN);
- }
- }
- /* remove fixed header if no rates were added */
-- if ((current_val - current_ev) > IW_EV_LCP_LEN) {
-+ if ((current_val - current_ev) > iwe_stream_lcp_len(req->info)) {
- current_ev = current_val;
- } else {
- /* We ran out of space in the buffer. */
-@@ -1704,7 +1714,8 @@
- iwe.cmd = IWEVCUSTOM;
- snprintf(buf, sizeof(buf), "bcn_int=%d", se->se_intval);
- iwe.u.data.length = strlen(buf);
-- current_ev = iwe_stream_add_point(current_ev, end_buf, &iwe, buf);
-+ current_ev = iwe_stream_add_point(req->info, current_ev,
-+ end_buf, &iwe, buf);
-
- /* We ran out of space in the buffer. */
- if (last_ev == current_ev)
-@@ -1728,8 +1739,8 @@
- rsn_leader, sizeof(rsn_leader) - 1);
- #endif
- if (iwe.u.data.length != 0) {
-- current_ev = iwe_stream_add_point(current_ev, end_buf,
-- &iwe, buf);
-+ current_ev = iwe_stream_add_point(req->info,
-+ current_ev, end_buf, &iwe, buf);
-
- /* We ran out of space in the buffer */
- if (last_ev == current_ev)
-@@ -1754,8 +1765,8 @@
- wpa_leader, sizeof(wpa_leader) - 1);
- #endif
- if (iwe.u.data.length != 0) {
-- current_ev = iwe_stream_add_point(current_ev, end_buf,
-- &iwe, buf);
-+ current_ev = iwe_stream_add_point(req->info,
-+ current_ev, end_buf, &iwe, buf);
-
- /* We ran out of space in the buffer. */
- if (last_ev == current_ev)
-@@ -1773,8 +1784,8 @@
- se->se_wme_ie, se->se_wme_ie[1] + 2,
- wme_leader, sizeof(wme_leader) - 1);
- if (iwe.u.data.length != 0) {
-- current_ev = iwe_stream_add_point(current_ev, end_buf,
-- &iwe, buf);
-+ current_ev = iwe_stream_add_point(req->info,
-+ current_ev, end_buf, &iwe, buf);
-
- /* We ran out of space in the buffer. */
- if (last_ev == current_ev)
-@@ -1791,8 +1802,8 @@
- se->se_ath_ie, se->se_ath_ie[1] + 2,
- ath_leader, sizeof(ath_leader) - 1);
- if (iwe.u.data.length != 0) {
-- current_ev = iwe_stream_add_point(current_ev, end_buf,
-- &iwe, buf);
-+ current_ev = iwe_stream_add_point(req->info,
-+ current_ev, end_buf, &iwe, buf);
-
- /* We ran out of space in the buffer. */
- if (last_ev == current_ev)
-@@ -1815,6 +1826,7 @@
- int res = 0;
-
- req.vap = vap;
-+ req.info = info;
- req.current_ev = extra;
- if (data->length == 0) {
- req.end_buf = extra + IW_SCAN_MAX_DATA;
-
diff --git a/net-wireless/madwifi-ng/files/madwifi-ng-0.9.4-request_module-build.patch b/net-wireless/madwifi-ng/files/madwifi-ng-0.9.4-request_module-build.patch
deleted file mode 100644
index ad338a3b70e0..000000000000
--- a/net-wireless/madwifi-ng/files/madwifi-ng-0.9.4-request_module-build.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-http://bugs.gentoo.org/show_bug.cgi?id=232099
-http://madwifi-project.org/changeset/3880
-
-=== modified file 'include/compat.h'
---- include/compat.h 2009-01-31 16:01:16 +0000
-+++ include/compat.h 2009-01-31 16:03:33 +0000
-@@ -175,6 +175,10 @@
- #define DEV_ATH CTL_UNNUMBERED
- #endif
-
-+#if LINUX_VERSION_CODE < KERNEL_VERSION(2,6,0)
-+#define request_module(_fmt, _modname) request_module(_modname)
-+#endif
-+
- #endif /* __KERNEL__ */
-
- #endif /* _ATH_COMPAT_H_ */
-
-=== modified file 'net80211/ieee80211_linux.c'
---- net80211/ieee80211_linux.c 2009-01-31 16:01:16 +0000
-+++ net80211/ieee80211_linux.c 2009-01-31 16:03:09 +0000
-@@ -335,7 +335,7 @@
- {
- #ifdef CONFIG_KMOD
- int rv;
-- rv = request_module(modname);
-+ rv = request_module("%s", modname);
- if (rv < 0)
- printk(KERN_ERR "failed to automatically load module: %s; " \
- "errno: %d\n", modname, rv);
-
diff --git a/net-wireless/madwifi-ng/files/madwifi-ng-injection-r3925.patch b/net-wireless/madwifi-ng/files/madwifi-ng-injection-r3925.patch
deleted file mode 100644
index 1999184ec5ae..000000000000
--- a/net-wireless/madwifi-ng/files/madwifi-ng-injection-r3925.patch
+++ /dev/null
@@ -1,32 +0,0 @@
-=== modified file 'ath/if_ath.c'
---- ath/if_ath.c 2009-06-03 07:46:17 +0000
-+++ ath/if_ath.c 2009-06-03 07:53:24 +0000
-@@ -2359,6 +2359,7 @@
- ath_tx_startraw(struct net_device *dev, struct ath_buf *bf, struct sk_buff *skb)
- {
- struct ath_softc *sc = netdev_priv(dev);
-+ struct ieee80211com *ic = &sc->sc_ic;
- struct ath_hal *ah = sc->sc_ah;
- struct ieee80211_phy_params *ph = (struct ieee80211_phy_params *) (skb->cb + sizeof(struct ieee80211_cb));
- const HAL_RATE_TABLE *rt;
-@@ -2375,7 +2376,8 @@
- struct ieee80211_frame *wh;
-
- wh = (struct ieee80211_frame *) skb->data;
-- try0 = ph->try0;
-+ //try0 = ph->try0;
-+ try0 = (ic->ic_opmode == IEEE80211_M_MONITOR) ? 1 : ph->try0;
- rt = sc->sc_currates;
- txrate = dot11_to_ratecode(sc, rt, ph->rate0);
- power = ph->power > 60 ? 60 : ph->power;
-@@ -2404,7 +2406,8 @@
- KASSERT(rt != NULL, ("no rate table, mode %u", sc->sc_curmode));
-
-
-- if (IEEE80211_IS_MULTICAST(wh->i_addr1)) {
-+ if (IEEE80211_IS_MULTICAST(wh->i_addr1) || ((ic->ic_opmode ==
-+ IEEE80211_M_MONITOR) && (skb->data[1]&3) != 0x01) ) {
- flags |= HAL_TXDESC_NOACK; /* no ack on broad/multicast */
- sc->sc_stats.ast_tx_noack++;
- try0 = 1;
-
diff --git a/net-wireless/madwifi-ng/files/madwifi-ng-r1886.patch b/net-wireless/madwifi-ng/files/madwifi-ng-r1886.patch
deleted file mode 100644
index 1ee11bec1c3f..000000000000
--- a/net-wireless/madwifi-ng/files/madwifi-ng-r1886.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-allow to inject packets with aircrack-ng
-
-diff -ur ath/if_ath.c ath/if_ath.c
---- ath/if_ath.c 2007-01-07 21:22:55.312500000 +0100
-+++ ath/if_ath.c 2007-01-07 21:17:09.875000000 +0100
-@@ -2289,6 +2289,7 @@
- ath_tx_startraw(struct net_device *dev, struct ath_buf *bf, struct sk_buff *skb)
- {
- struct ath_softc *sc = dev->priv;
-+ struct ieee80211com *ic = &sc->sc_ic;
- struct ath_hal *ah = sc->sc_ah;
- struct ieee80211_phy_params *ph = (struct ieee80211_phy_params *) (skb->cb + sizeof(struct ieee80211_cb));
- const HAL_RATE_TABLE *rt;
-@@ -2305,7 +2306,11 @@
- struct ieee80211_frame *wh;
-
- wh = (struct ieee80211_frame *) skb->data;
-- try0 = ph->try0;
-+ try0 = (ic->ic_opmode == IEEE80211_M_MONITOR) ? 1 : ph->try0;
-+ /*
-+ * The retry value has to be patched to 1 when injecting,
-+ * otherwise the sequence number will be overwritten
-+ */
- rt = sc->sc_currates;
- txrate = dot11_to_ratecode(sc, rt, ph->rate0);
- power = ph->power > 60 ? 60 : ph->power;