summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/orinoco-fwutils/orinoco-fwutils-0.3.ebuild')
-rw-r--r--net-wireless/orinoco-fwutils/orinoco-fwutils-0.3.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-wireless/orinoco-fwutils/orinoco-fwutils-0.3.ebuild b/net-wireless/orinoco-fwutils/orinoco-fwutils-0.3.ebuild
new file mode 100644
index 000000000000..4fb2d4717ea8
--- /dev/null
+++ b/net-wireless/orinoco-fwutils/orinoco-fwutils-0.3.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+DESCRIPTION="ORiNOCO IEEE 802.11 wireless LAN firmware utilities"
+HOMEPAGE="http://www.nongnu.org/orinoco/"
+SRC_URI="mirror://sourceforge/orinoco/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+IUSE=""
+RDEPEND="app-arch/unzip
+ dev-lang/perl
+ net-misc/wget
+ sys-apps/coreutils
+ sys-apps/sed"
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+
+ # fix paths
+ for file in "${S}"/get_*; do
+ sed -i \
+ -e "s:parse_:/usr/bin/parse_:g" \
+ -e "s:\./::g" \
+ ${file}
+ done
+}
+
+src_install() {
+ dobin get_* parse_*
+
+ dodoc README SHA1SUM
+}
+
+pkg_postinst() {
+ elog "After fetching the firmware using these tools you must place it in"
+ elog "/lib/firmware/ for the kernel driver to be able to load it."
+}