summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/urh/urh-1.5.5.ebuild')
-rw-r--r--net-wireless/urh/urh-1.5.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-wireless/urh/urh-1.5.5.ebuild b/net-wireless/urh/urh-1.5.5.ebuild
new file mode 100644
index 000000000000..27b0f19a2c8c
--- /dev/null
+++ b/net-wireless/urh/urh-1.5.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5} )
+inherit distutils-r1 eutils
+
+DESCRIPTION="Universal Radio Hacker: investigate wireless protocols like a boss"
+HOMEPAGE="https://github.com/jopohl/urh"
+SRC_URI="https://github.com/jopohl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="hackrf rtlsdr"
+
+DEPEND="${PYTHON_DEPS}
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ hackrf? ( net-libs/libhackrf )
+ rtlsdr? ( net-wireless/rtl-sdr )"
+RDEPEND="${DEPEND}
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ net-wireless/gr-osmosdr"
+
+python_configure_all() {
+ mydistutilsargs=(
+ $(use_with hackrf)
+ $(use_with rtlsdr)
+ )
+}