summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/astrometry/files/astrometry-0.67-soname.patch')
-rw-r--r--sci-astronomy/astrometry/files/astrometry-0.67-soname.patch25
1 files changed, 25 insertions, 0 deletions
diff --git a/sci-astronomy/astrometry/files/astrometry-0.67-soname.patch b/sci-astronomy/astrometry/files/astrometry-0.67-soname.patch
new file mode 100644
index 000000000000..595dd79a2f46
--- /dev/null
+++ b/sci-astronomy/astrometry/files/astrometry-0.67-soname.patch
@@ -0,0 +1,25 @@
+Author: Ole Streicher <olebole@debian.org>
+Description: Add SONAME to libastrometry.so
+--- a/blind/Makefile
++++ b/blind/Makefile
+@@ -148,7 +148,8 @@
+ $(RANLIB) $@
+
+ $(ENGINE_SO): $(ENGINE_OBJS) $(SLIB)
+- $(CC) $(LDFLAGS) $(SHAREDLIBFLAGS) -o $@ $^ $(LDLIBS)
++ $(CC) $(LDFLAGS) $(SHAREDLIBFLAGS) -Wl,-soname,$@.0 -o $@.0 $^ $(LDLIBS)
++ ln -s $@.0 $@
+
+ # old and miscellaneous executables that aren't part of the pipeline.
+ OLDEXECS := plotquads rawstartree checkquads
+@@ -233,8 +234,8 @@
+ done
+ mkdir -p '$(LIB_INSTALL_DIR)'
+ @for x in $(INSTALL_LIB); do \
+- echo cp $$x '$(LIB_INSTALL_DIR)'; \
+- cp $$x '$(LIB_INSTALL_DIR)'; \
++ echo cp -d $$x* '$(LIB_INSTALL_DIR)'; \
++ cp -d $$x* '$(LIB_INSTALL_DIR)'; \
+ done
+ mkdir -p '$(PY_INSTALL_DIR)'
+ @for x in $(PYTHON_INSTALL); do \