summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/cdsclient')
-rw-r--r--sci-astronomy/cdsclient/Manifest1
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.8.4-r1.ebuild (renamed from sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild)30
-rw-r--r--sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild41
-rw-r--r--sci-astronomy/cdsclient/files/cdsclient-makefile.patch18
-rw-r--r--sci-astronomy/cdsclient/metadata.xml2
5 files changed, 27 insertions, 65 deletions
diff --git a/sci-astronomy/cdsclient/Manifest b/sci-astronomy/cdsclient/Manifest
index bbd2da686b74..842309b4edd3 100644
--- a/sci-astronomy/cdsclient/Manifest
+++ b/sci-astronomy/cdsclient/Manifest
@@ -1,2 +1 @@
-DIST cdsclient-3.81.tar.gz 122719 BLAKE2B 4db50f2552e4379797d395b272eb2dbefd4b16b9b6acd459fc306738c600b1e86370f7720d6927c36b1504d3e4d316b08ae642756a7a29c9b07aef75df48369c SHA512 3fcf7a902dfddb3583ff34eedbcddd6a5641bf9c87d234159090378436ac370313ea311d3fee6e202ee84b3fe4065ef45a46a15b5d996e05afd1418e617c20ea
DIST cdsclient-3.84.tar.gz 119585 BLAKE2B cf5d7fe3e7a1f4985949b8621122157178b856e82415e6bf12a582c67e6748bf9eb75209983baab9051919817b373b198748cfda5a1e4733784a9b98ab7659ff SHA512 2d7abf0079189b9dd19cb8919061445fd19ea9f7dfd54e8ceee26b743218cf62ab00eba0147abe82d9294223927f04b4cc3328620dfc9184a7049f8d515b29e4
diff --git a/sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild b/sci-astronomy/cdsclient/cdsclient-3.8.4-r1.ebuild
index 4ca690324256..3087cd4f8f5b 100644
--- a/sci-astronomy/cdsclient/cdsclient-3.8.1.ebuild
+++ b/sci-astronomy/cdsclient/cdsclient-3.8.4-r1.ebuild
@@ -1,41 +1,31 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-
-inherit eutils versionator
+EAPI=8
# upstream versioning wrong: 3.71 is really 3.7.1
-MYP="${PN}-$(delete_version_separator 2)"
+MYP="${PN}-$(ver_rs 2 '')"
DESCRIPTION="Collection of scripts to access the CDS databases"
HOMEPAGE="http://cdsweb.u-strasbg.fr/doc/cdsclient.html"
SRC_URI="ftp://cdsarc.u-strasbg.fr/pub/sw/${MYP}.tar.gz"
+S="${WORKDIR}/${MYP}"
LICENSE="all-rights-reserved"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
RESTRICT="mirror bindist"
-DEPEND=""
-RDEPEND="app-shells/tcsh"
-S="${WORKDIR}/${MYP}"
+RDEPEND="app-shells/tcsh"
-PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
-src_prepare() {
- default
- # remove non standard "mantex" page
- sed -e 's/aclient.tex//' -i configure || die
-}
+PATCHES=( "${FILESDIR}"/${PN}-makefile.patch )
src_install() {
local bindir="${EPREFIX}/usr/bin/${PN}"
emake DESTDIR="${D}" SHSDIR="${D}${bindir}" install
- cat <<-EOF > 99${PN}
- PATH=${bindir}
- ROOTPATH=${bindir}
+
+ newenvd - 99${PN} <<-EOF
+ PATH="${bindir}"
+ ROOTPATH="${bindir}"
EOF
- doenvd 99${PN}
}
diff --git a/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild b/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild
deleted file mode 100644
index 868a8b7c0c88..000000000000
--- a/sci-astronomy/cdsclient/cdsclient-3.8.4.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit eutils versionator
-
-# upstream versioning wrong: 3.71 is really 3.7.1
-MYP="${PN}-$(delete_version_separator 2)"
-
-DESCRIPTION="Collection of scripts to access the CDS databases"
-HOMEPAGE="http://cdsweb.u-strasbg.fr/doc/cdsclient.html"
-SRC_URI="ftp://cdsarc.u-strasbg.fr/pub/sw/${MYP}.tar.gz"
-
-LICENSE="all-rights-reserved"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-RESTRICT="mirror bindist"
-DEPEND=""
-RDEPEND="app-shells/tcsh"
-
-S="${WORKDIR}/${MYP}"
-
-PATCHES=( "${FILESDIR}/${PN}-makefile.patch" )
-src_prepare() {
- default
- # remove non standard "mantex" page
- sed -e 's/aclient.tex//' -i configure || die
-}
-
-src_install() {
- local bindir="${EPREFIX}/usr/bin/${PN}"
- emake DESTDIR="${D}" SHSDIR="${D}${bindir}" install
- cat <<-EOF > 99${PN}
- PATH=${bindir}
- ROOTPATH=${bindir}
- EOF
- doenvd 99${PN}
-}
diff --git a/sci-astronomy/cdsclient/files/cdsclient-makefile.patch b/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
index 6d135a622056..d07928219b40 100644
--- a/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
+++ b/sci-astronomy/cdsclient/files/cdsclient-makefile.patch
@@ -1,5 +1,19 @@
---- cdsclient-3.81/Makefile.in.orig 2016-02-26 17:33:14.217750589 +0000
-+++ cdsclient-3.81/Makefile.in 2016-02-26 17:38:22.463875411 +0000
+- remove non standard "mantex" page
+- respect user flags
+
+--- a/configure
++++ b/configure
+@@ -3938,7 +3938,7 @@
+
+
+ EXPORT_SOURCE_FILE="aclient.c wwwget.c skio.c skclient.c sk.h"
+-EXPORT_MAN_FILE="sk.3 aclient.1 wwwget.1 aclient.tex"
++EXPORT_MAN_FILE="sk.3 aclient.1 wwwget.1 "
+ EXPORT_MAN_TEX="man.tex"
+ CASE="dev"
+
+--- a/Makefile.in
++++ b/Makefile.in
@@ -31,17 +31,17 @@
#################################################################
#PREFIX = /usr/local
diff --git a/sci-astronomy/cdsclient/metadata.xml b/sci-astronomy/cdsclient/metadata.xml
index 4df574f63e63..d154a0b106d2 100644
--- a/sci-astronomy/cdsclient/metadata.xml
+++ b/sci-astronomy/cdsclient/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci-astronomy@gentoo.org</email>