summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/funtools/files/funtools-1.4.4-makefiles.patch')
-rw-r--r--sci-astronomy/funtools/files/funtools-1.4.4-makefiles.patch341
1 files changed, 0 insertions, 341 deletions
diff --git a/sci-astronomy/funtools/files/funtools-1.4.4-makefiles.patch b/sci-astronomy/funtools/files/funtools-1.4.4-makefiles.patch
deleted file mode 100644
index d1045b643176..000000000000
--- a/sci-astronomy/funtools/files/funtools-1.4.4-makefiles.patch
+++ /dev/null
@@ -1,341 +0,0 @@
-diff -Nur funtools-1.4.4.orig/filter/Makefile.in funtools-1.4.4/filter/Makefile.in
---- funtools-1.4.4.orig/filter/Makefile.in 2014-03-04 08:35:59.665478514 -0800
-+++ funtools-1.4.4/filter/Makefile.in 2014-03-04 08:36:38.196760766 -0800
-@@ -29,6 +29,9 @@
-
- prefix = @prefix@
- exec_prefix = @exec_prefix@
-+bindir = @bindir@
-+includedir = @includedir@
-+libdir = @libdir@
-
- # The following definition can be set to non-null for special systems
- # like AFS with replication. It allows the pathnames used for installation
-@@ -38,13 +41,13 @@
- INSTALL_ROOT =
-
- # Directory in which to install the .a, .so, and .o files:
--LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
-+LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
-
- # Directory in which to install the programs:
--BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
-+BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
-
- # Directory in which to install the include files:
--INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
-+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/funtools/filter
-
- # util files are in the util directory at same level
- UTIL_INC = -I../util
-@@ -55,7 +58,7 @@
- #FITSY_LIBS = -L../fitsy
-
- # wcs files are in the wcs subdirectory
--WCS_INC = -I../wcs
-+#WCS_INC = -I../wcs
- #WCS_LIBS = -L../wcs -lwcs
-
- # extra includes for compiling
-@@ -161,7 +164,7 @@
- do \
- if [ ! -d $$i ] ; then \
- echo "Making directory $$i"; \
-- mkdir $$i; \
-+ mkdir -p $$i; \
- chmod 755 $$i; \
- else true; \
- fi; \
-@@ -228,6 +231,10 @@
-
- swap_c.h: swap.c inc.sed
- $(RM) swap_c.h
-+ ./inc.sed SWAP_C < swap.c > swap_c.h
-+
-+swap_c.h: swap.c inc.sed
-+ $(RM) swap_c.h
- ./inc.sed SWAP_C < swap.c > swap_c.h
-
- events_c.h: evfilter.c inc.sed
-diff -Nur funtools-1.4.4.orig/fitsy/Makefile.in funtools-1.4.4/fitsy/Makefile.in
---- funtools-1.4.4.orig/fitsy/Makefile.in 2014-03-04 08:35:59.638478312 -0800
-+++ funtools-1.4.4/fitsy/Makefile.in 2014-03-04 08:36:38.197760773 -0800
-@@ -28,6 +28,11 @@
-
- prefix = @prefix@
- exec_prefix = @exec_prefix@
-+bindir = @bindir@
-+includedir = @includedir@
-+mandir = @mandir@
-+datadir = @datadir@
-+libdir = @libdir@
-
- # The following definition can be set to non-null for special systems
- # like AFS with replication. It allows the pathnames used for installation
-@@ -37,13 +42,13 @@
- INSTALL_ROOT =
-
- # Directory in which to install the .a, .so, and .o files:
--LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
-+LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
-
- # Directory in which to install the programs:
--BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
-+BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
-
- # Directory in which to install the include files:
--INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
-+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/funtools/fitsy
-
- # There are just too many different versions of "install" around;
- # better to use the install-sh script that comes with the distribution,
-@@ -187,7 +192,7 @@
- do \
- if [ ! -d $$i ] ; then \
- echo "Making directory $$i"; \
-- mkdir $$i; \
-+ mkdir -p $$i; \
- chmod 755 $$i; \
- else true; \
- fi; \
-diff -Nur funtools-1.4.4.orig/gnu/Makefile.in funtools-1.4.4/gnu/Makefile.in
---- funtools-1.4.4.orig/gnu/Makefile.in 2014-03-04 08:35:59.642478341 -0800
-+++ funtools-1.4.4/gnu/Makefile.in 2014-03-04 08:36:38.197760773 -0800
-@@ -21,6 +21,11 @@
-
- prefix = @prefix@
- exec_prefix = @exec_prefix@
-+bindir = @bindir@
-+includedir = @includedir@
-+mandir = @mandir@
-+datadir = @datadir@
-+libdir = @libdir@
-
- # The following definition can be set to non-null for special systems
- # like AFS with replication. It allows the pathnames used for installation
-@@ -53,13 +58,13 @@
- EXTRA_OBJS = @EXTRA_OBJS@
-
- # Directory in which to install the .a, .so, and .o files:
--LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
-+LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
-
- # Directory in which to install the programs:
--BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
-+BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
-
- # Directory in which to install the include files:
--INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
-+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)
-
- # There are just too many different versions of "install" around;
- # better to use the install-sh script that comes with the distribution,
-diff -Nur funtools-1.4.4.orig/Makefile.in funtools-1.4.4/Makefile.in
---- funtools-1.4.4.orig/Makefile.in 2014-03-04 08:35:59.665478514 -0800
-+++ funtools-1.4.4/Makefile.in 2014-03-04 08:37:40.214224788 -0800
-@@ -28,28 +28,33 @@
-
- prefix = @prefix@
- exec_prefix = @exec_prefix@
-+bindir = @bindir@
-+includedir = @includedir@
-+mandir = @mandir@
-+datadir = @datadir@
-+libdir = @libdir@
-
- # The following definition can be set to non-null for special systems
- # like AFS with replication. It allows the pathnames used for installation
- # to be different than those used for actually reference files at
- # run-time. INSTALL_ROOT is prepended to $prefix and $exec_prefix
- # when installing files.
--INSTALL_ROOT =
-+INSTALL_ROOT = $(DESTDIR)
-
- # Directory in which to install the .a or .so binary for the FUNTOOLS library:
--LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
-+LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
-
- # Directory in which to install the program wish:
--BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
-+BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
-
- # Directory in which to install the funtools.h include file:
--INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
-+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/funtools
-
- # Top-level directory for manual entries:
--MAN_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/man
-+MAN_INSTALL_DIR = $(INSTALL_ROOT)$(mandir)
-
- # Top-level directory for share entries:
--MAN_SHARE_DIR = $(INSTALL_ROOT)$(prefix)/share/funtools
-+MAN_SHARE_DIR = $(INSTALL_ROOT)$(datadir)/funtools
-
- # util files are in the util subdirectory
- UTIL_INC = -I./util
-@@ -60,8 +65,8 @@
- # FITSY_LIBS = -L./fitsy -lfitsy
-
- # wcs files are in the wcs subdirectory
--WCS_INC = -I./wcs
--# WCS_LIBS = -L./wcs -lwcs
-+#WCS_INC = -I../wcs
-+#WCS_LIBS = -L./wcs -lwcs
-
- # filter files are in the filter subdirectory
- FILTER_INC = -I./filter
-@@ -160,7 +165,7 @@
-
- # this is used in the link line
- # LLIB = $(LIB)
--LLIB = @LLIB@
-+LLIB = -L. -lfuntools
-
- # libraries containing main as subroutines
- MAINLIB = lib$(PACKAGE)MainLib.a
-@@ -188,7 +193,7 @@
-
- # Subdirectories to run make in for the primary targets.
-
--SUBLIBS = util fitsy wcs filter
-+SUBLIBS = util fitsy filter
-
- SUBDIRS = $(SUBLIBS) gnu funtest faq
-
-@@ -225,10 +230,10 @@
- echo $(PROGS) | ./mkfunmainlib > funmainlib.c;
-
- shlib: sublib $(LIBOBJS)
-- @(rm -rf $(PACKAGE)tmp; mkdir $(PACKAGE)tmp; \
-+ @(rm -rf $(PACKAGE)tmp; mkdir -p $(PACKAGE)tmp; \
- (cd $(PACKAGE)tmp && ar x ../$(LIB)); \
- CC='$(CC)' CXX=$(CXX) \
-- ./mklib -o $(PACKAGE) $(PACKAGE)tmp/*.o; \
-+ ./mklib $(PACKAGE)tmp/*.o $(LIBS) -o $(PACKAGE) ; \
- rm -rf $(PACKAGE)tmp;)
-
- mainlib: $(MAINLIBOBJS) funmainlib.o lex.calc.o
-@@ -237,7 +242,7 @@
- $(RANLIB) lib$(PACKAGE)MainLib.a)
-
- shmainlib: mainlib
-- @(rm -rf $(PACKAGE)tmp; mkdir $(PACKAGE)tmp; \
-+ @(rm -rf $(PACKAGE)tmp; mkdir -p $(PACKAGE)tmp; \
- (cd $(PACKAGE)tmp && ar x ../lib$(PACKAGE)MainLib.a); \
- CC='$(CC)' CXX='$(CXX)' \
- ./mklib -o $(PACKAGE)MainLib -L. -lfuntools $(PACKAGE)tmp/*.o;\
-@@ -248,7 +253,7 @@
- $(RANLIB) libtclfun.a)
-
- shtclfun: tclfun
-- @(rm -rf $(PACKAGE)tmp; mkdir $(PACKAGE)tmp; \
-+ @(rm -rf $(PACKAGE)tmp; mkdir -p $(PACKAGE)tmp; \
- (cd $(PACKAGE)tmp && ar x ../$(LIB) && ar x ../libtclfun.a); \
- CC='$(CC)' CXX='$(CXX)' \
- ./mklib -o tclfun $(PACKAGE)tmp/*.o; \
-@@ -386,7 +391,7 @@
- @for dir in $(SUBDIRS); do \
- echo " "; \
- echo Installing in $$dir ...; \
-- (cd $$dir; $(MAKE) $@) ; \
-+ (cd $$dir; $(MAKE) INSTALL_ROOT=$(INSTALL_ROOT) INCLUDE_INSTALL_DIR=$(INCLUDE_INSTALL_DIR) $@) ; \
- done
-
- install:: install-man
-@@ -422,7 +427,7 @@
- do \
- if [ ! -d $$i ] ; then \
- echo "Making directory $$i"; \
-- mkdir $$i; \
-+ mkdir -p $$i; \
- chmod 755 $$i; \
- else true; \
- fi; \
-@@ -462,7 +467,7 @@
- install-man:
- @if [ ! -d $(MAN_INSTALL_DIR) ] ; then \
- echo "Making directory $(MAN_INSTALL_DIR)"; \
-- mkdir $(MAN_INSTALL_DIR); \
-+ mkdir -p $(MAN_INSTALL_DIR); \
- chmod 755 $(MAN_INSTALL_DIR); \
- else true; \
- fi;
-@@ -473,7 +478,7 @@
- M="$(MAN_INSTALL_DIR)/man$$E"; \
- if [ ! -d $$M ] ; then \
- echo "Making directory $$M"; \
-- mkdir $$M; \
-+ mkdir -p $$M; \
- chmod 755 $$M; \
- else true; \
- fi; \
-diff -Nur funtools-1.4.4.orig/util/Makefile.in funtools-1.4.4/util/Makefile.in
---- funtools-1.4.4.orig/util/Makefile.in 2014-03-04 08:35:59.653478425 -0800
-+++ funtools-1.4.4/util/Makefile.in 2014-03-04 08:36:38.197760773 -0800
-@@ -29,6 +29,11 @@
-
- prefix = @prefix@
- exec_prefix = @exec_prefix@
-+bindir = @bindir@
-+includedir = @includedir@
-+mandir = @mandir@
-+datadir = @datadir@
-+libdir = @libdir@
-
- # The following definition can be set to non-null for special systems
- # like AFS with replication. It allows the pathnames used for installation
-@@ -38,13 +43,13 @@
- INSTALL_ROOT =
-
- # Directory in which to install the .a, .so, and .o files:
--LIB_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/lib
-+LIB_INSTALL_DIR = $(INSTALL_ROOT)$(libdir)
-
- # Directory in which to install the programs:
--BIN_INSTALL_DIR = $(INSTALL_ROOT)$(exec_prefix)/bin
-+BIN_INSTALL_DIR = $(INSTALL_ROOT)$(bindir)
-
- # Directory in which to install the include files:
--INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(prefix)/include
-+INCLUDE_INSTALL_DIR = $(INSTALL_ROOT)$(includedir)/funtools/util
-
- # extra includes for compiling
- INCLUDES =
-@@ -200,12 +205,24 @@
- tlaunch2: tlaunch2.o
- $(CC) $(LDFLAGS) tlaunch2.o -o tlaunch2
-
-+tlaunch.o: tlaunch.c
-+
-+tlaunch: tlaunch.o launch.o $(LIB)
-+ $(CC) $(LDFLAGS) tlaunch.o launch.o -o tlaunch $(LIB) $(LIBS) \
-+ $(EXTRA_LIBS)
-+
-+tlaunch2.o: tlaunch2.c
-+
-+tlaunch2: tlaunch2.o
-+ $(CC) $(LDFLAGS) tlaunch2.o -o tlaunch2
-+
-+
- install-binaries: $(LIB) $(PROGS)
- @for i in $(LIB_INSTALL_DIR) $(INCLUDE_INSTALL_DIR) $(BIN_INSTALL_DIR) ; \
- do \
- if [ ! -d $$i ] ; then \
- echo "Making directory $$i"; \
-- mkdir $$i; \
-+ mkdir -p $$i; \
- chmod 755 $$i; \
- else true; \
- fi; \
-@@ -272,4 +289,11 @@
- purift $(CC) $(LDFLAGS) tlaunch.o xlaunch.o -o tlaunch \
- $(LIB) $(LIBS) $(EXTRA_LIBS)
-
-+pure: tlaunch.pure
-+
-+tlaunch.pure: tlaunch.o launch.o $(LIB)
-+ purift $(CC) $(LDFLAGS) tlaunch.o launch.o -o tlaunch \
-+ $(LIB) $(LIBS) $(EXTRA_LIBS)
-+
-+
- # DO NOT DELETE THIS LINE -- make depend depends on it.