summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild')
-rw-r--r--sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild b/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild
index ff1ebd1455cc..32762bcf8728 100644
--- a/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild
+++ b/sci-astronomy/xfitsview/xfitsview-2.2-r2.ebuild
@@ -1,7 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+inherit toolchain-funcs
MY_PN=XFITSview
MY_P=${MY_PN}${PV}
@@ -9,26 +11,28 @@ MY_P=${MY_PN}${PV}
DESCRIPTION="Viewer for astronomical images in FITS format"
HOMEPAGE="http://www.nrao.edu/software/fitsview/"
SRC_URI="ftp://ftp.cv.nrao.edu/fits/os-support/unix/xfitsview/${PN}${PV}.tgz"
+S="${WORKDIR}/${MY_PN}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE=""
DEPEND=">=x11-libs/motif-2.3:0"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/${MY_PN}
-
-DOCS=( README changes notes.text )
PATCHES=( "${FILESDIR}"/${P}-build_system.patch )
src_prepare() {
default
- find "${S}" -name '*old.c' -delete || die
+ find -name '*old.c' -delete || die
+}
+
+src_configure() {
+ tc-export AR
+ default
}
src_install() {
dobin XFITSview
- einstalldocs
+ dodoc README changes notes.text
}