summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/allpathslg/allpathslg-42337.ebuild')
-rw-r--r--sci-biology/allpathslg/allpathslg-42337.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-biology/allpathslg/allpathslg-42337.ebuild b/sci-biology/allpathslg/allpathslg-42337.ebuild
new file mode 100644
index 000000000000..9fb44dfcc905
--- /dev/null
+++ b/sci-biology/allpathslg/allpathslg-42337.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="De novo assembly of whole-genome shotgun microreads"
+HOMEPAGE="http://www.broadinstitute.org/science/programs/genome-biology/crd"
+SRC_URI="ftp://ftp.broadinstitute.org/pub/crd/ALLPATHS/Release-LG/latest_source_code/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 -x86"
+
+DEPEND="
+ dev-libs/boost
+ !sci-biology/allpaths
+ sci-biology/vaal"
+RDEPEND=""
+
+src_prepare() {
+ sed -i 's/-ggdb3//' configure.ac || die
+ eautoreconf
+}
+
+src_install() {
+ einstall || die
+ # Provided by sci-biology/vaal
+ for i in QueryLookupTable ScaffoldAccuracy MakeLookupTable Fastb ShortQueryLookup; do
+ rm "${D}/usr/bin/$i" || die
+ done
+}