summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/bioruby')
-rw-r--r--sci-biology/bioruby/Manifest1
-rw-r--r--sci-biology/bioruby/bioruby-1.4.3.0001-r1.ebuild38
-rw-r--r--sci-biology/bioruby/bioruby-9999.ebuild41
-rw-r--r--sci-biology/bioruby/files/bioruby-1.4.3.0001-fix-tests.patch29
-rw-r--r--sci-biology/bioruby/metadata.xml5
5 files changed, 114 insertions, 0 deletions
diff --git a/sci-biology/bioruby/Manifest b/sci-biology/bioruby/Manifest
new file mode 100644
index 000000000000..9c1f1499ea6f
--- /dev/null
+++ b/sci-biology/bioruby/Manifest
@@ -0,0 +1 @@
+DIST bioruby-1.4.3.0001.tar.gz 1500656 SHA256 20d6548e1c5977464afd74019693dde9e45a030d48d974db08a7b85c4214fb35 SHA512 77ad96388e1e8b1dccab582a3bc309b99b36cac1803f79b42707fc4dbf439de31ed491ce5e1c2e59f695643756ae0df2e275bbcd9ad6827f251b52edd677d821 WHIRLPOOL ccb952d4cd3b8700acbf356a0965842b068aa2fb861dfab58e7442e5570ab79604a8be1fb86a9d80d6bc9a8f9dc886daf98cb84fe7298b4f334e0e6be198f9e7
diff --git a/sci-biology/bioruby/bioruby-1.4.3.0001-r1.ebuild b/sci-biology/bioruby/bioruby-1.4.3.0001-r1.ebuild
new file mode 100644
index 000000000000..b50f3fa137fb
--- /dev/null
+++ b/sci-biology/bioruby/bioruby-1.4.3.0001-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
+LICENSE="Ruby"
+HOMEPAGE="http://www.bioruby.org/"
+SRC_URI="http://www.${PN}.org/archive/${P}.tar.gz"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 ~ppc x86"
+
+ruby_add_rdepend "dev-ruby/libxml"
+
+PATCHES=( "${FILESDIR}"/${P}-fix-tests.patch )
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
+}
+
+each_ruby_test() {
+ ${RUBY} -rubygems test/runner.rb || die
+}
diff --git a/sci-biology/bioruby/bioruby-9999.ebuild b/sci-biology/bioruby/bioruby-9999.ebuild
new file mode 100644
index 000000000000..838f8430c972
--- /dev/null
+++ b/sci-biology/bioruby/bioruby-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20"
+EGIT_REPO_URI="git://github.com/bioruby/bioruby.git
+ https://github.com/bioruby/bioruby.git"
+
+inherit git-2 ruby-fakegem
+
+DESCRIPTION="An integrated environment for bioinformatics using the Ruby language"
+LICENSE="Ruby"
+HOMEPAGE="http://www.bioruby.org/"
+SRC_URI=""
+SLOT="0"
+IUSE=""
+KEYWORDS=""
+
+ruby_add_rdepend "dev-ruby/libxml"
+
+all_ruby_unpack() {
+ git-2_src_unpack
+}
+
+each_ruby_configure() {
+ ${RUBY} setup.rb config || die
+}
+
+each_ruby_compile() {
+ ${RUBY} setup.rb setup || die
+}
+
+each_ruby_install() {
+ ${RUBY} setup.rb install --prefix="${D}" || die
+}
+
+each_ruby_test() {
+ ${RUBY} -rubygems test/runner.rb || die
+}
diff --git a/sci-biology/bioruby/files/bioruby-1.4.3.0001-fix-tests.patch b/sci-biology/bioruby/files/bioruby-1.4.3.0001-fix-tests.patch
new file mode 100644
index 000000000000..71c4ca27104a
--- /dev/null
+++ b/sci-biology/bioruby/files/bioruby-1.4.3.0001-fix-tests.patch
@@ -0,0 +1,29 @@
+From edda65b8fb32c2eee6b0652074981c31aa68b0eb Mon Sep 17 00:00:00 2001
+From: Naohisa Goto <ng@bioruby.org>
+Date: Fri, 23 Aug 2013 23:51:59 +0900
+Subject: [PATCH] Test bug fix: Read test file with binary mode to avoid
+ encoding error
+
+ * Test bug fix: Read test file with binary mode to avoid string encoding
+ error. Thanks to nieder (github.com/nieder) who reports the bug.
+ (https://github.com/bioruby/bioruby/issues/84)
+---
+ test/unit/bio/db/test_phyloxml.rb | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/test/unit/bio/db/test_phyloxml.rb b/test/unit/bio/db/test_phyloxml.rb
+index 0744c64..c24278d 100644
+--- a/test/unit/bio/db/test_phyloxml.rb
++++ b/test/unit/bio/db/test_phyloxml.rb
+@@ -100,7 +100,7 @@ def test_open_with_block
+ end
+
+ def test_new
+- str = File.read(TestPhyloXMLData.example_xml)
++ str = File.open(TestPhyloXMLData.example_xml, "rb") { |f| f.read }
+ assert_instance_of(Bio::PhyloXML::Parser,
+ phyloxml = Bio::PhyloXML::Parser.new(str))
+ common_test_next_tree(phyloxml)
+--
+1.8.4
+
diff --git a/sci-biology/bioruby/metadata.xml b/sci-biology/bioruby/metadata.xml
new file mode 100644
index 000000000000..d4648212cbad
--- /dev/null
+++ b/sci-biology/bioruby/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>