summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/blossoc')
-rw-r--r--sci-biology/blossoc/Manifest1
-rw-r--r--sci-biology/blossoc/blossoc-1.4.0.ebuild31
-rw-r--r--sci-biology/blossoc/files/blossoc-1.4.0-gcc43.patch15
-rw-r--r--sci-biology/blossoc/metadata.xml5
4 files changed, 52 insertions, 0 deletions
diff --git a/sci-biology/blossoc/Manifest b/sci-biology/blossoc/Manifest
new file mode 100644
index 000000000000..96859ca6bf5f
--- /dev/null
+++ b/sci-biology/blossoc/Manifest
@@ -0,0 +1 @@
+DIST blossoc-1.4.0.tar.gz 194885 SHA256 b23f51349f72f31263b8aca162c7590a5f52b72fd5e0d91b4a2591098ff5bdbe
diff --git a/sci-biology/blossoc/blossoc-1.4.0.ebuild b/sci-biology/blossoc/blossoc-1.4.0.ebuild
new file mode 100644
index 000000000000..7e5b6694d395
--- /dev/null
+++ b/sci-biology/blossoc/blossoc-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools eutils
+
+DESCRIPTION="A linkage disequilibrium association mapping tool"
+HOMEPAGE="http://www.daimi.au.dk/~mailund/Blossoc/"
+SRC_URI="http://www.daimi.au.dk/~mailund/Blossoc/download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND="sci-libs/gsl
+ dev-libs/boost
+ sci-biology/snpfile"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i '/TESTS += first_test.sh/ d' "${S}/Makefile.am" || die
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ eautoreconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+}
diff --git a/sci-biology/blossoc/files/blossoc-1.4.0-gcc43.patch b/sci-biology/blossoc/files/blossoc-1.4.0-gcc43.patch
new file mode 100644
index 000000000000..d8e354c1745f
--- /dev/null
+++ b/sci-biology/blossoc/files/blossoc-1.4.0-gcc43.patch
@@ -0,0 +1,15 @@
+Fixes build with >=GCC-4.3
+
+http://bugs.gentoo.org/show_bug.cgi?id=292949
+
+Patch written by Sebastian Luther <SebastianLuther@gmx.de>
+--- pph.cc
++++ pph.cc
+@@ -23,6 +23,7 @@
+ */
+
+ #include "pph.hh"
++#include <cstdio>
+ #include <cmath>
+ #include <snpfile/matrix.hh>
+ using namespace BiRC::SNPFile;
diff --git a/sci-biology/blossoc/metadata.xml b/sci-biology/blossoc/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/blossoc/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>