summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch')
-rw-r--r--sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch b/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch
new file mode 100644
index 000000000000..004742546f00
--- /dev/null
+++ b/sci-biology/infernal/files/infernal-1.0.2-parallel-build.patch
@@ -0,0 +1,31 @@
+Fix parallel build
+
+http://bugs.gentoo.org/show_bug.cgi?id=311919
+
+--- Makefile.in
++++ Makefile.in
+@@ -82,9 +82,10 @@
+ all: core
+
+ core:
+- (cd easel; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make)
+- (cd src; make CC="$(CC)" CFLAGS="$(CFLAGS)"; make module)
+- (cd testsuite; make CC="$(CC)" CFLAGS="$(CFLAGS)")
++ $(MAKE) -C easel
++ $(MAKE) -C src
++ $(MAKE) -C src module
++ $(MAKE) -C testsuite
+
+ #.PHONY: $(RIGFILTERS)
+ #$(RIGFILTERS): core
+--- easel/Makefile.in
++++ easel/Makefile.in
+@@ -132,7 +132,7 @@
+ esl_wuss.o
+
+ all: libeasel.a
+- (cd miniapps; make)
++ $(MAKE) -C miniapps
+
+ .c.o:
+ ${CC} -I. ${CFLAGS} ${SIMDFLAGS} ${DEFS} -c $<