summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/mcl/mcl-08.312.ebuild')
-rw-r--r--sci-biology/mcl/mcl-08.312.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sci-biology/mcl/mcl-08.312.ebuild b/sci-biology/mcl/mcl-08.312.ebuild
new file mode 100644
index 000000000000..9a2aafb0c037
--- /dev/null
+++ b/sci-biology/mcl/mcl-08.312.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils
+
+MY_P="${PN}-${PV/./-}"
+
+DESCRIPTION="A Markov Cluster Algorithm implementation"
+HOMEPAGE="http://micans.org/mcl/"
+SRC_URI="http://micans.org/mcl/src/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+blast"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ find \
+ -name Makefile.am \
+ -exec sed \
+ -e '/docdir/d' \
+ -e '/exampledir/s:doc::g' \
+ -i '{}' + || die
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=( $(use_enable blast) )
+ autotools-utils_src_configure
+}