summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/mothur/mothur-1.6.0.ebuild')
-rw-r--r--sci-biology/mothur/mothur-1.6.0.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sci-biology/mothur/mothur-1.6.0.ebuild b/sci-biology/mothur/mothur-1.6.0.ebuild
new file mode 100644
index 000000000000..034f6fae1a65
--- /dev/null
+++ b/sci-biology/mothur/mothur-1.6.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="A suite of algorithms for ecological bioinformatics"
+HOMEPAGE="http://www.mothur.org/"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND="app-arch/unzip"
+RDEPEND=""
+
+S="${WORKDIR}/mothur-v.${PV}"
+
+src_prepare() {
+ sed \
+ -e 's/CC_OPTIONS =.*$/CC_OPTIONS = ${CXXFLAGS} /' \
+ -e 's|CC = g++|CC = '$(tc-getCXX)'|' \
+ -e '/^LNK_OPTIONS/s:$:${LDFLAGS}:g' \
+ -i makefile || die
+}
+
+src_install() {
+ dobin ${PN}
+}