summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/newick-utils')
-rw-r--r--sci-biology/newick-utils/Manifest2
-rw-r--r--sci-biology/newick-utils/metadata.xml5
-rw-r--r--sci-biology/newick-utils/newick-utils-1.3.0.ebuild25
-rw-r--r--sci-biology/newick-utils/newick-utils-1.5.0.ebuild25
4 files changed, 57 insertions, 0 deletions
diff --git a/sci-biology/newick-utils/Manifest b/sci-biology/newick-utils/Manifest
new file mode 100644
index 000000000000..fa2d5255b412
--- /dev/null
+++ b/sci-biology/newick-utils/Manifest
@@ -0,0 +1,2 @@
+DIST newick-utils-1.3.0.tar.gz 6872730 SHA256 2c4d364a6b74d484b795681a08f648e1c89c373e6aa29c2b84bf690530bc54ee
+DIST newick-utils-1.5.0.tar.gz 7400423 SHA256 b5508ff31228c8d9fc9fb2e9b70aa24192248998c4e315dd82135323c05e1f67
diff --git a/sci-biology/newick-utils/metadata.xml b/sci-biology/newick-utils/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/newick-utils/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/newick-utils/newick-utils-1.3.0.ebuild b/sci-biology/newick-utils/newick-utils-1.3.0.ebuild
new file mode 100644
index 000000000000..94c51c218310
--- /dev/null
+++ b/sci-biology/newick-utils/newick-utils-1.3.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="Tools for processing phylogenetic trees (re-root, subtrees, trimming, pruning, condensing, drawing)"
+HOMEPAGE="http://cegg.unige.ch/newick_utils"
+SRC_URI="http://cegg.unige.ch/pub/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS="amd64 x86"
+
+DEPEND=""
+RDEPEND="!dev-games/libnw"
+
+src_install() {
+ einstall || die
+}
+
+src_test() {
+ emake -C tests check-TESTS || die
+}
diff --git a/sci-biology/newick-utils/newick-utils-1.5.0.ebuild b/sci-biology/newick-utils/newick-utils-1.5.0.ebuild
new file mode 100644
index 000000000000..6bf8d108ca81
--- /dev/null
+++ b/sci-biology/newick-utils/newick-utils-1.5.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+DESCRIPTION="Tools for processing phylogenetic trees (re-root, subtrees, trimming, pruning, condensing, drawing)"
+HOMEPAGE="http://cegg.unige.ch/newick_utils"
+SRC_URI="http://cegg.unige.ch/pub/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=""
+RDEPEND="!dev-games/libnw"
+
+src_install() {
+ einstall || die
+}
+
+src_test() {
+ emake -C tests check-TESTS || die
+}