summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/probcons')
-rw-r--r--sci-biology/probcons/Manifest1
-rw-r--r--sci-biology/probcons/files/gcc-4.3.patch44
-rw-r--r--sci-biology/probcons/files/probcons-1.12-cxxflags.patch47
-rw-r--r--sci-biology/probcons/files/probcons-1.12-gcc-4.6.patch15
-rw-r--r--sci-biology/probcons/metadata.xml5
-rw-r--r--sci-biology/probcons/probcons-1.12-r1.ebuild53
6 files changed, 165 insertions, 0 deletions
diff --git a/sci-biology/probcons/Manifest b/sci-biology/probcons/Manifest
new file mode 100644
index 000000000000..1d0739662628
--- /dev/null
+++ b/sci-biology/probcons/Manifest
@@ -0,0 +1 @@
+DIST probcons_v1_12.tar.gz 43200 SHA256 ecf3f9ab9ad47e14787c76d1c64aeea5533d4038c4be0236c00cdd79104cf383
diff --git a/sci-biology/probcons/files/gcc-4.3.patch b/sci-biology/probcons/files/gcc-4.3.patch
new file mode 100644
index 000000000000..37c45c03a98f
--- /dev/null
+++ b/sci-biology/probcons/files/gcc-4.3.patch
@@ -0,0 +1,44 @@
+diff -u probcons.orig/CompareToRef.cc probcons/CompareToRef.cc
+--- probcons.orig/CompareToRef.cc 2008-04-08 16:38:46.000000000 -0700
++++ probcons/CompareToRef.cc 2008-04-08 16:39:41.000000000 -0700
+@@ -16,6 +16,7 @@
+ #include <limits>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <cerrno>
+ #include <iomanip>
+
+diff -u probcons.orig/FixRef.cc probcons/FixRef.cc
+--- probcons.orig/FixRef.cc 2008-04-08 16:38:46.000000000 -0700
++++ probcons/FixRef.cc 2008-04-08 16:39:33.000000000 -0700
+@@ -17,6 +17,7 @@
+ #include <algorithm>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <cerrno>
+ #include <iomanip>
+
+diff -u probcons.orig/Main.cc probcons/Main.cc
+--- probcons.orig/Main.cc 2008-04-08 16:38:46.000000000 -0700
++++ probcons/Main.cc 2008-04-08 16:39:14.000000000 -0700
+@@ -21,6 +21,7 @@
+ #include <climits>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <cerrno>
+ #include <iomanip>
+
+diff -u probcons.orig/ProjectPairwise.cc probcons/ProjectPairwise.cc
+--- probcons.orig/ProjectPairwise.cc 2008-04-08 16:38:46.000000000 -0700
++++ probcons/ProjectPairwise.cc 2008-04-08 16:39:25.000000000 -0700
+@@ -16,6 +16,7 @@
+ #include <limits>
+ #include <cstdio>
+ #include <cstdlib>
++#include <cstring>
+ #include <cerrno>
+ #include <iomanip>
+
diff --git a/sci-biology/probcons/files/probcons-1.12-cxxflags.patch b/sci-biology/probcons/files/probcons-1.12-cxxflags.patch
new file mode 100644
index 000000000000..e07ebe1a613f
--- /dev/null
+++ b/sci-biology/probcons/files/probcons-1.12-cxxflags.patch
@@ -0,0 +1,47 @@
+diff --git a/Makefile b/Makefile
+index 75fc47a..4a19140 100644
+--- a/Makefile
++++ b/Makefile
+@@ -15,6 +15,8 @@ CXX = g++
+ # c) RELEASE mode
+ ################################################################################
+
++OPT_CXXFLAGS = -O3 -W -Wall -pedantic -funroll-loops
++
+ OTHERFLAGS = -DNumInsertStates=2 -DVERSION="1.12"
+
+ # debug mode
+@@ -25,7 +27,7 @@ OTHERFLAGS = -DNumInsertStates=2 -DVERSION="1.12"
+
+ # release mode
+ #CXXFLAGS = -O3 -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS) -mmmx -msse -msse2 -mfpmath=sse -march=pentium4 -mcpu=pentium4 -funroll-loops -fomit-frame-pointer
+-CXXFLAGS = -O3 -W -Wall -pedantic -DNDEBUG $(OTHERFLAGS) -funroll-loops
++CXXFLAGS = $(OPT_CXXFLAGS) -DNDEBUG $(OTHERFLAGS)
+
+ ################################################################################
+ # 3) Dependencies
+@@ -37,19 +39,19 @@ TARGETS = probcons compare project makegnuplot
+ all : $(TARGETS)
+
+ probcons : MultiSequence.h ProbabilisticModel.h ScoreType.h Sequence.h FileBuffer.h SparseMatrix.h EvolutionaryTree.h Defaults.h SafeVector.h Main.cc
+- $(CXX) $(CXXFLAGS) -lm -o probcons Main.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o probcons Main.cc -lm
+
+ compare : MultiSequence.h Sequence.h FileBuffer.h SafeVector.h CompareToRef.cc
+- $(CXX) $(CXXFLAGS) -o compare CompareToRef.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o compare CompareToRef.cc
+
+ fixref : MultiSequence.h ProbabilisticModel.h ScoreType.h Sequence.h FileBuffer.h SparseMatrix.h EvolutionaryTree.h Defaults.h SafeVector.h FixRef.cc
+- $(CXX) $(CXXFLAGS) -o fixref FixRef.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o fixref FixRef.cc
+
+ project : MultiSequence.h Sequence.h SafeVector.h ProjectPairwise.cc
+- $(CXX) $(CXXFLAGS) -o project ProjectPairwise.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o project ProjectPairwise.cc
+
+ makegnuplot : MakeGnuPlot.cc
+- $(CXX) $(CXXFLAGS) -o makegnuplot MakeGnuPlot.cc
++ $(CXX) $(LDFLAGS) $(CXXFLAGS) -o makegnuplot MakeGnuPlot.cc
+
+ .PHONY : clean
+ clean:
diff --git a/sci-biology/probcons/files/probcons-1.12-gcc-4.6.patch b/sci-biology/probcons/files/probcons-1.12-gcc-4.6.patch
new file mode 100644
index 000000000000..1596f3b31916
--- /dev/null
+++ b/sci-biology/probcons/files/probcons-1.12-gcc-4.6.patch
@@ -0,0 +1,15 @@
+ SafeVector.h | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/SafeVector.h b/SafeVector.h
+index abf4b64..9c3292e 100644
+--- a/SafeVector.h
++++ b/SafeVector.h
+@@ -8,6 +8,7 @@
+ #ifndef SAFEVECTOR_H
+ #define SAFEVECTOR_H
+
++#include <cstddef>
+ #include <cassert>
+ #include <vector>
+
diff --git a/sci-biology/probcons/metadata.xml b/sci-biology/probcons/metadata.xml
new file mode 100644
index 000000000000..f17a827e3101
--- /dev/null
+++ b/sci-biology/probcons/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-biology</herd>
+</pkgmetadata>
diff --git a/sci-biology/probcons/probcons-1.12-r1.ebuild b/sci-biology/probcons/probcons-1.12-r1.ebuild
new file mode 100644
index 000000000000..1b3e76cd92ba
--- /dev/null
+++ b/sci-biology/probcons/probcons-1.12-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}_v${PV/./_}"
+
+DESCRIPTION="Probabilistic Consistency-based Multiple Alignment of Amino Acid Sequences"
+HOMEPAGE="http://probcons.stanford.edu/"
+SRC_URI="http://probcons.stanford.edu/${MY_P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+# Gnuplot is explicitly runtime-only, it's run using system()
+RDEPEND="
+ !sci-geosciences/gmt
+ sci-visualization/gnuplot"
+DEPEND=""
+
+S="${WORKDIR}/${PN}"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-cxxflags.patch \
+ "${FILESDIR}"/gcc-4.3.patch \
+ "${FILESDIR}"/${P}-gcc-4.6.patch
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ OPT_CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ dobin probcons project makegnuplot
+ # Overlap with imagemagick
+ newbin compare compare-probcons
+ dodoc README
+}
+
+pkg_postinst() {
+ ewarn "The 'compare' binary is installed as 'compare-probcons'"
+ ewarn "to avoid overlap with other packages."
+ einfo "You may also want to download the user manual"
+ einfo "from http://probcons.stanford.edu/manual.pdf"
+}