summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/recon')
-rw-r--r--sci-biology/recon/files/recon-1.08-Wimplicit-function-declaration.patch20
-rw-r--r--sci-biology/recon/metadata.xml2
-rw-r--r--sci-biology/recon/recon-1.08-r1.ebuild (renamed from sci-biology/recon/recon-1.08.ebuild)16
3 files changed, 29 insertions, 9 deletions
diff --git a/sci-biology/recon/files/recon-1.08-Wimplicit-function-declaration.patch b/sci-biology/recon/files/recon-1.08-Wimplicit-function-declaration.patch
new file mode 100644
index 000000000000..9eba16e4a410
--- /dev/null
+++ b/sci-biology/recon/files/recon-1.08-Wimplicit-function-declaration.patch
@@ -0,0 +1,20 @@
+--- a/src/bolts.h
++++ b/src/bolts.h
+@@ -3,6 +3,7 @@
+ #include <stdio.h>
+ #include <math.h>
+ #include <stdlib.h>
++#include <stdint.h>
+
+
+ #define NAME_LEN 50
+--- a/src/seqlist.h
++++ b/src/seqlist.h
+@@ -1,6 +1,7 @@
+
+ #include "bolts.h"
+ #include "string.h"
++#include <ctype.h>
+
+ #ifndef _seqlist_h
+ #define _seqlist_h
diff --git a/sci-biology/recon/metadata.xml b/sci-biology/recon/metadata.xml
index 959160fe46b1..ccdff086e20b 100644
--- a/sci-biology/recon/metadata.xml
+++ b/sci-biology/recon/metadata.xml
@@ -1,5 +1,5 @@
<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer type="project">
<email>sci-biology@gentoo.org</email>
diff --git a/sci-biology/recon/recon-1.08.ebuild b/sci-biology/recon/recon-1.08-r1.ebuild
index a96403c812be..dd79dd43c496 100644
--- a/sci-biology/recon/recon-1.08.ebuild
+++ b/sci-biology/recon/recon-1.08-r1.ebuild
@@ -1,31 +1,31 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
inherit toolchain-funcs
DESCRIPTION="Automated de novo identification of repeat families from genomic sequences"
HOMEPAGE="http://www.repeatmasker.org/RepeatModeler.html"
SRC_URI="http://www.repeatmasker.org/${P^^}.tar.gz"
+S="${WORKDIR}/${P^^}"
LICENSE="GPL-2"
SLOT="0"
-IUSE="examples"
KEYWORDS="~amd64 ~x86"
+IUSE="examples"
RDEPEND="dev-lang/perl"
-S=${WORKDIR}/${P^^}
-
PATCHES=(
"${FILESDIR}"/${PN}-1.08-buffer-overflow.patch
"${FILESDIR}"/${PN}-1.08-perl-shebangs.patch
+ "${FILESDIR}"/${PN}-1.08-Wimplicit-function-declaration.patch
)
src_prepare() {
default
- sed -i "s|$path = \"\";|$path = \"${EPREFIX}/usr/libexec/${PN}\";|" scripts/recon.pl || die
+ sed -i "s|$path = \"\";|$path = \"${EPREFIX}/usr/libexec/recon\";|" scripts/recon.pl || die
}
src_compile() {
@@ -35,13 +35,13 @@ src_compile() {
src_install() {
dobin scripts/*
- exeinto /usr/libexec/${PN}
+ exeinto /usr/libexec/recon
doexe src/{edgeredef,eledef,eleredef,famdef,imagespread}
newdoc {00,}README
if use examples; then
- insinto /usr/share/${PN}
+ insinto /usr/share/recon
doins -r Demos
fi
}