summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-biology/trnascan-se/files')
-rw-r--r--sci-biology/trnascan-se/files/trnascan-se-1.31-clang16.patch62
-rw-r--r--sci-biology/trnascan-se/files/trnascan-se-1.31-ldflags.patch26
-rw-r--r--sci-biology/trnascan-se/files/trnascan-se-1.31-makefile.patch140
-rw-r--r--sci-biology/trnascan-se/files/trnascan-se-1.31-portable-perl-shebangs.patch32
4 files changed, 234 insertions, 26 deletions
diff --git a/sci-biology/trnascan-se/files/trnascan-se-1.31-clang16.patch b/sci-biology/trnascan-se/files/trnascan-se-1.31-clang16.patch
new file mode 100644
index 000000000000..33889c90cf69
--- /dev/null
+++ b/sci-biology/trnascan-se/files/trnascan-se-1.31-clang16.patch
@@ -0,0 +1,62 @@
+https://bugs.gentoo.org/874477
+--- a/eufind_main.c
++++ b/eufind_main.c
+@@ -23,4 +23,5 @@
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #include "squid.h"
+ #include "sqfuncs.h"
+@@ -47,4 +48,14 @@
+ -i <integer> : start nucleotide numbering at <integer> (def=1)\n\n";
+
++int GetBbox(float*, int*, char*, int, int, int);
++int GetBestABox(TRNA_TYPE*, char*, char*, int, int, int, int, int);
++int GetBestTrxTerm(TRNA_TYPE*, char*, int, float);
++int GetSecABox(TRNA_TYPE*, char*);
++void Get_tRNA_stats(TRNA_TYPE*, char*, int, int);
++int Init_tRNA(TRNA_TYPE*);
++int IntEncodeSeq(char*, char*, int);
++void Save_tRNA(TRNA_TYPE*, SQINFO*, char*, int, int, long int);
++int tRNAOverlap(TRNA_TYPE*, TRNA_TYPE*, int);
++
+ int
+ main (int argc, char **argv)
+--- a/scan_main.c
++++ b/scan_main.c
+@@ -8,4 +8,5 @@
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #include <time.h>
+ #include <math.h>
+--- a/score_main.c
++++ b/score_main.c
+@@ -10,4 +10,5 @@
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #include <time.h>
+ #include <math.h>
+--- a/trnascan.c
++++ b/trnascan.c
+@@ -69,4 +69,5 @@
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <unistd.h>
+ #include <ctype.h>
+
+@@ -333,5 +334,5 @@
+ );
+
+-main(int argc, char **argv)
++int main(int argc, char **argv)
+ {
+ /* pointers to the different files fpi=input file, fpo=output file,
+@@ -1419,5 +1420,5 @@
+ /* Calls to this function eliminated for efficiency T. Lowe 11/95 */
+
+-myindex (char *s, char *t)
++int myindex (char *s, char *t)
+ {
+ int i, j, k;
diff --git a/sci-biology/trnascan-se/files/trnascan-se-1.31-ldflags.patch b/sci-biology/trnascan-se/files/trnascan-se-1.31-ldflags.patch
deleted file mode 100644
index f28b1e8f6bb0..000000000000
--- a/sci-biology/trnascan-se/files/trnascan-se-1.31-ldflags.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-diff --git a/Makefile b/Makefile
-index 53e5c5b..a2d3feb 100644
---- a/Makefile
-+++ b/Makefile
-@@ -109,17 +109,17 @@ MPOBJ = mpviterbi.o mp-dbviterbi.o
- all: $(PROGS) tRNAscan-SE setpaths
-
- covels-SE: $(OBJ) scan_main.o
-- $(CC) $(CFLAGS) $(RFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
-+ $(CC) $(CFLAGS) $(RFLAGS) $(LDFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
-
- coves-SE: $(OBJ) score_main.o
-- $(CC) $(CFLAGS) $(RFLAGS) -o coves-SE score_main.o $(OBJ) $(LIBS)
-+ $(CC) $(CFLAGS) $(RFLAGS) $(LDFLAGS) -o coves-SE score_main.o $(OBJ) $(LIBS)
-
- eufindtRNA: $(SQUIDOBJ) pavesi.o eufind_main.o
-- $(CC) $(CFLAGS) -o eufindtRNA eufind_main.o \
-+ $(CC) $(CFLAGS) $(LDFLAGS) -o eufindtRNA eufind_main.o \
- pavesi.o $(SQUIDOBJ) $(LIBS)
-
- trnascan-1.4: trnascan.o
-- $(CC) $(CFLAGS) -DTSCANDIR=\"$(LIBDIR)\" -o trnascan-1.4 trnascan.c
-+ $(CC) $(CFLAGS) -DTSCANDIR=\"$(LIBDIR)\" $(LDFLAGS) -o trnascan-1.4 trnascan.c
-
- tRNAscan-SE:
- $(PERLDIR)/$(PERLBIN) checkversion.pl
diff --git a/sci-biology/trnascan-se/files/trnascan-se-1.31-makefile.patch b/sci-biology/trnascan-se/files/trnascan-se-1.31-makefile.patch
new file mode 100644
index 000000000000..acf3c2a6d862
--- /dev/null
+++ b/sci-biology/trnascan-se/files/trnascan-se-1.31-makefile.patch
@@ -0,0 +1,140 @@
+--- a/Makefile
++++ b/Makefile
+@@ -20,9 +20,9 @@
+ PERLBIN = perl
+
+ ## where you want things installed
+-BINDIR = $(HOME)/bin
+-LIBDIR = $(HOME)/lib/tRNAscan-SE
+-MANDIR = $(HOME)/man
++BINDIR = $(EPREFIX)/usr/bin
++LIBDIR = $(EPREFIX)/usr/share/trnascan-se
++MANDIR = $(EPREFIX)/usr/share/man
+
+ ## NOTE !! If you later manually move the location of
+ ## binaries or data files in the BINDIR or LIBDIR directories,
+@@ -33,10 +33,8 @@
+ TEMPDIR = /tmp
+
+ ## your compiler
+-CC = gcc # GNU cc (if available) otherwise use vendor's cc
+
+ ## any special compiler flags you want
+-CFLAGS = -O # ok for most machines (remove -O for DEC OSF/1 cc compiler)
+
+ ## machine specific definitions
+ # You shouldn't need any. The specific #define's in squid are historical.
+@@ -58,7 +56,7 @@
+ #######
+
+ SHELL = /bin/sh
+-LIBS = -lm
++LIBS += -lm
+ .SUFFIXES : .c .o
+
+ DOCS = README MANUAL INSTALL COPYING GNULICENSE FILES Release.history
+@@ -109,20 +107,20 @@
+ all: $(PROGS) tRNAscan-SE setpaths
+
+ covels-SE: $(OBJ) scan_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(RFLAGS) -o covels-SE scan_main.o $(OBJ) $(LIBS)
+
+ coves-SE: $(OBJ) score_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o coves-SE score_main.o $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(RFLAGS) -o coves-SE score_main.o $(OBJ) $(LIBS)
+
+ eufindtRNA: $(SQUIDOBJ) pavesi.o eufind_main.o
+- $(CC) $(CFLAGS) -o eufindtRNA eufind_main.o \
++ $(CC) $(LDFLAGS) $(CFLAGS) -o eufindtRNA eufind_main.o \
+ pavesi.o $(SQUIDOBJ) $(LIBS)
+
+-trnascan-1.4: trnascan.o
+- $(CC) $(CFLAGS) -DTSCANDIR=\"$(LIBDIR)\" -o trnascan-1.4 trnascan.c
++trnascan-1.4: trnascan.c
++ $(CC) $(LDFLAGS) $(CFLAGS) $(CPPFLAGS) -DTSCANDIR=\"$(LIBDIR)\" -o trnascan-1.4 trnascan.c
+
+ tRNAscan-SE:
+- $(PERLDIR)/$(PERLBIN) checkversion.pl
++ $(PERLBIN) checkversion.pl
+ sed 's#/tmp#$(TEMPDIR)#g' tRNAscan-SE.src | \
+ sed 's#bindir = ""#bindir =\"$(BINDIR)/"#g' | \
+ sed 's#/usr/local/lib/tRNAscanSE#$(LIBDIR)#g' | \
+@@ -200,11 +198,11 @@
+ noambig: trnascan-1.4-NA eufindtRNA-NA
+
+ trnascan-1.4-NA: trnascan.o
+- $(CC) $(CFLAGS) -DNO_AMBIG -DTSCANDIR=\"$(LIBDIR)\" -o trnascan-1.4-NA trnascan.c
++ $(CC) $(LDFLAGS) $(CFLAGS) $(CPPFLAGS) -DNO_AMBIG -DTSCANDIR=\"$(LIBDIR)\" -o trnascan-1.4-NA trnascan.c
+
+ eufindtRNA-NA: $(SQUIDOBJ) eufind_main.o
+- $(CC) $(CFLAGS) -DNO_AMBIG -c -o pavesi-NA.o pavesi.c
+- $(CC) $(CFLAGS) -o eufindtRNA-NA eufind_main.o \
++ $(CC) $(CFLAGS) $(CPPFLAGS) -DNO_AMBIG -c -o pavesi-NA.o pavesi.c
++ $(CC) $(LDFLAGS) $(CFLAGS) -o eufindtRNA-NA eufind_main.o \
+ pavesi-NA.o $(SQUIDOBJ) $(LIBS)
+
+
+@@ -220,7 +218,7 @@
+ rmdir -ps $(MANDIR)
+
+ .c.o:
+- $(CC) $(CFLAGS) $(MDEFS) -c $<
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(MDEFS) -c $<
+
+ ## programs from Sean Eddy's sequence i/o function library not
+ ## needed for tRNAscan-SE but included for their utility
+@@ -233,16 +231,16 @@
+ cp $(UTILS) $(BINDIR)/.
+
+ reformat: $(SQUIDOBJ) reformat_main.o
+- $(CC) $(CFLAGS) $(MDEFS) -o reformat $(SQUIDOBJ) reformat_main.o $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(MDEFS) -o reformat $(SQUIDOBJ) reformat_main.o $(LIBS)
+
+ revcomp: $(SQUIDOBJ) revcomp_main.o
+- $(CC) $(CFLAGS) $(MDEFS) -o revcomp $(SQUIDOBJ) revcomp_main.o $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(MDEFS) -o revcomp $(SQUIDOBJ) revcomp_main.o $(LIBS)
+
+ seqstat: $(SQUIDOBJ) seqstat_main.o
+- $(CC) $(CFLAGS) $(MDEFS) -o seqstat $(SQUIDOBJ) seqstat_main.o $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(MDEFS) -o seqstat $(SQUIDOBJ) seqstat_main.o $(LIBS)
+
+ shuffle: $(SQUIDOBJ) shuffle_main.o
+- $(CC) $(CFLAGS) $(MDEFS) -o shuffle $(SQUIDOBJ) shuffle_main.o $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(MDEFS) -o shuffle $(SQUIDOBJ) shuffle_main.o $(LIBS)
+
+ ## other programs in Cove package (below) not needed for
+ ## tRNAscan-SE, but are included for users who wish to apply
+@@ -255,25 +253,25 @@
+ cp $(COVE_SUITE) $(BINDIR)/.
+
+ covea: $(OBJ) align_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o covea align_main.o $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(RFLAGS) -o covea align_main.o $(OBJ) $(LIBS)
+
+ coveb: $(OBJ) build_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o coveb build_main.o $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(RFLAGS) -o coveb build_main.o $(OBJ) $(LIBS)
+
+ covee: $(OBJ) emit_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o covee emit_main.o $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(RFLAGS) -o covee emit_main.o $(OBJ) $(LIBS)
+
+ covet: $(OBJ) train_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o covet train_main.o $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(RFLAGS) -o covet train_main.o $(OBJ) $(LIBS)
+
+ covels: $(OBJ) scan_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o covels scan_main.o $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(RFLAGS) -o covels scan_main.o $(OBJ) $(LIBS)
+
+ coves: $(OBJ) score_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o coves score_main.o $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(RFLAGS) -o coves score_main.o $(OBJ) $(LIBS)
+
+ structcheck: $(OBJ) structcheck_main.o
+- $(CC) $(CFLAGS) $(RFLAGS) -o structcheck structcheck_main.o $(OBJ) $(LIBS)
++ $(CC) $(LDFLAGS) $(CFLAGS) $(RFLAGS) -o structcheck structcheck_main.o $(OBJ) $(LIBS)
+
+
+ ## Maspar memory limits
diff --git a/sci-biology/trnascan-se/files/trnascan-se-1.31-portable-perl-shebangs.patch b/sci-biology/trnascan-se/files/trnascan-se-1.31-portable-perl-shebangs.patch
new file mode 100644
index 000000000000..187705e8b3a0
--- /dev/null
+++ b/sci-biology/trnascan-se/files/trnascan-se-1.31-portable-perl-shebangs.patch
@@ -0,0 +1,32 @@
+--- a/fasta2gsi.pl
++++ b/fasta2gsi.pl
+@@ -1,4 +1,4 @@
+-#! /usr/bin/perl
++#!/usr/bin/env perl
+
+ # Usage: fasta2gsi.perl <seqfile>
+ # Creates seqfile.gsi
+--- a/instman.pl
++++ b/instman.pl
+@@ -1,4 +1,4 @@
+-#! /usr/bin/perl
++#!/usr/bin/env perl
+
+ # Sean Eddy, Wed Jul 29 15:24:43 1992
+
+--- a/sstofa.pl
++++ b/sstofa.pl
+@@ -1,4 +1,4 @@
+-#! /usr/bin/perl
++#!/usr/bin/env perl
+
+
+ if ($#ARGV < 0) {
+--- a/tRNAscan-SE.src
++++ b/tRNAscan-SE.src
+@@ -1,4 +1,4 @@
+-#! /usr/bin/perl
++#!/usr/bin/env perl
+ #
+ # --------------------------------------------------------------------
+ # tRNAscan-SE: a program for improved detection of transfer RNA