summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/gonvert/gonvert-0.2.39.ebuild')
-rw-r--r--sci-calculators/gonvert/gonvert-0.2.39.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sci-calculators/gonvert/gonvert-0.2.39.ebuild b/sci-calculators/gonvert/gonvert-0.2.39.ebuild
new file mode 100644
index 000000000000..e8eb5a74ff53
--- /dev/null
+++ b/sci-calculators/gonvert/gonvert-0.2.39.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-single-r1
+
+DESCRIPTION="Unit conversion utility written in PyGTK"
+HOMEPAGE="http://unihedron.com/projects/gonvert/index.php"
+SRC_URI="http://unihedron.com/projects/gonvert/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygtk:2[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}"/0.2.23-paths.patch )
+
+src_install () {
+ emake install DESTDIR="${D}" prefix="${EPREFIX}/usr"
+ python_fix_shebang "${ED%/}"/usr/bin
+ rm -fr "${ED%/}/usr/share/doc/${PN}" || die
+ einstalldocs
+}