summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/pcalc/pcalc-2.ebuild')
-rw-r--r--sci-calculators/pcalc/pcalc-2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/sci-calculators/pcalc/pcalc-2.ebuild b/sci-calculators/pcalc/pcalc-2.ebuild
new file mode 100644
index 000000000000..d99ec312836a
--- /dev/null
+++ b/sci-calculators/pcalc/pcalc-2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+inherit toolchain-funcs
+
+DESCRIPTION="the programmers calculator"
+HOMEPAGE="https://github.com/vapier/pcalc"
+SRC_URI="mirror://sourceforge/pcalc/${P}.tar.lzma"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="sys-devel/flex"
+RDEPEND=""
+
+src_prepare() {
+ sed -i -e "s:/usr:${EPREFIX}/usr:g" Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake pcalc
+}