summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators/tilp2/tilp2-1.17-r1.ebuild')
-rw-r--r--sci-calculators/tilp2/tilp2-1.17-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-calculators/tilp2/tilp2-1.17-r1.ebuild b/sci-calculators/tilp2/tilp2-1.17-r1.ebuild
new file mode 100644
index 000000000000..e1f4e2e2a052
--- /dev/null
+++ b/sci-calculators/tilp2/tilp2-1.17-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=1
+inherit autotools-utils
+
+DESCRIPTION="Communication program for Texas Instruments calculators "
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls threads xinerama"
+
+RDEPEND="
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ x11-libs/gtk+:2
+ >=sci-libs/libticalcs2-1.1.8
+ >=sci-libs/libticables2-1.3
+ >=sci-libs/libtifiles2-1.1.6
+ >=sci-libs/libticonv-1.1.4
+ nls? ( virtual/libintl )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-proto/xineramaproto )"
+
+src_configure() {
+ # kde seems to be kde3 only
+ local myeconfargs=(
+ --disable-rpath
+ --without-kde
+ $(use_enable nls)
+ $(use_enable threads threading)
+ $(use_with xinerama)
+ )
+ autotools-utils_src_configure
+}