summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-calculators')
-rw-r--r--sci-calculators/units/Manifest1
-rw-r--r--sci-calculators/units/units-2.17.ebuild63
2 files changed, 0 insertions, 64 deletions
diff --git a/sci-calculators/units/Manifest b/sci-calculators/units/Manifest
index 30ecd40c9cc0..0265ac770116 100644
--- a/sci-calculators/units/Manifest
+++ b/sci-calculators/units/Manifest
@@ -1,4 +1,3 @@
DIST units-2.16.tar.gz 1178197 BLAKE2B 6de569cd70c8067be053c5acb0885f898b76252bf6bafbea5f8b4972eca0acb13adfb4b2bc70ef0a3df747ee31084076fea3d3199922f0c44fc8c6d08232192b SHA512 afca2bf313208db2d0a3f4e96fed7bb86a3e96030b420e1cfa68a140499b9a8f2ef8c166c1d608d03c9ca6260199569a67c67c623d8c6a4b8d52e9d5cb6e3091
-DIST units-2.17.tar.gz 1185070 BLAKE2B 44db938b214596058cdfaeda7fd8d70161221c196a0971b5a0e03331e30fdeb52db85ab43b721f25efd755f4baee4f92aa6204a85d38703a31ec7cac0cefd689 SHA512 e4114f7dc0e40146f969375511c5d930497cb9502306ef82feac78c8e09a03e84ed0b582ff82e2878beae41702c9612f7a3d28fc6e9ed2cfae708f9feb8b737b
DIST units-2.18.tar.gz 1248892 BLAKE2B b1dd86907ba6af3251577c533d6c39705ff4a8cdf099c15c61efaf7876ee9a4131212e09b3e9ca0f2355fc547256e33be4fcb9efc552b38e3e990e76b9465992 SHA512 2ae9f08acb03f2f443514800dafb454434d7d1a43497d2a937c2e9e8429f63d821be11ae3090693e8cadbd2f9cdeafba8f80c1671d84a9cceb0f72ad75d8cad7
DIST units-2.19.tar.gz 1271288 BLAKE2B b6d61661d88e8221d5689e7f1cdba357479d4e34c4c6fd51c336e76850521b3ad7d8f1bfd9ff8173917931151c8da2180928879be940358e35ae3e96a6e30765 SHA512 f28df8f0b95b53620d4d21ed369551b8510663ff3658293ba62de2722e7dc2d87506db7c65dc192e35f3c3a20842e8ed09ddaa7352532f7e3eaeab4c001061c8
diff --git a/sci-calculators/units/units-2.17.ebuild b/sci-calculators/units/units-2.17.ebuild
deleted file mode 100644
index 4d61f6f6676c..000000000000
--- a/sci-calculators/units/units-2.17.ebuild
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
-inherit eutils python-single-r1
-
-DESCRIPTION="Unit conversion program"
-HOMEPAGE="https://www.gnu.org/software/units/units.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="FDL-1.3 GPL-3"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
-IUSE="+units_cur"
-REQUIRED_USE="units_cur? ( ${PYTHON_REQUIRED_USE} )"
-
-RDEPEND="
- sys-libs/readline:=
- units_cur? (
- ${PYTHON_DEPS}
- dev-python/future[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- )
-"
-DEPEND="
- ${RDEPEND}
-"
-PATCHES=(
- "${FILESDIR}"/${PN}-2.17-network-sandbox.patch
-)
-
-pkg_setup() {
- use units_cur && python-single-r1_pkg_setup
-}
-
-src_configure() {
- econf \
- --sharedstatedir="${EROOT}/var/lib" \
- ac_cv_path_PYTHON=no
-}
-
-src_compile() {
- emake ${PN}
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- dodoc ChangeLog NEWS README
-
- # we're intentionally delaying this since 'make install' would
- # get confused if we shove 'units_cur' there, and there is no real
- # need to add more complexity for it
- if use units_cur; then
- sed \
- -e "/^outfile/s|'.*'|'/usr/share/units/currency.units'|g" \
- -e 's|^#!|&/usr/bin/python|g' \
- units_cur_inst > units_cur || die
- python_fix_shebang units_cur
- python_doscript units_cur
- fi
-}