summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/p3d')
-rw-r--r--sci-chemistry/p3d/Manifest1
-rw-r--r--sci-chemistry/p3d/metadata.xml21
-rw-r--r--sci-chemistry/p3d/p3d-0.4.3.ebuild35
-rw-r--r--sci-chemistry/p3d/p3d-9999.ebuild30
4 files changed, 87 insertions, 0 deletions
diff --git a/sci-chemistry/p3d/Manifest b/sci-chemistry/p3d/Manifest
new file mode 100644
index 000000000000..9b2f9b5b9c4d
--- /dev/null
+++ b/sci-chemistry/p3d/Manifest
@@ -0,0 +1 @@
+DIST p3d-0.4.3.tar.gz 7213577 RMD160 2a251097bf7f83b27e519b20e4110fe330b2b6a3 SHA1 ced099dcaa28517c6095c1153f3a19bb6c78494c SHA256 b968eb37c0d27ad1f4f46f8a942fb2b62fbcdb50b31a1e66875e2cdc036a9932
diff --git a/sci-chemistry/p3d/metadata.xml b/sci-chemistry/p3d/metadata.xml
new file mode 100644
index 000000000000..bd602bd0e68a
--- /dev/null
+++ b/sci-chemistry/p3d/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>sci-chemistry</herd>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+p3d was developed in order to offer a Python module that is powerful and fast,
+yet intuitive to use. The simplicity of p3d is due to the usage of object
+oriented programming (i.e. atoms are treated as vectors), the implementation
+of a query parser that translates queries readable by humans into a combination
+of algebra set operations the fact that no additional Python packages are
+necessary. The speed is due to the usage of a binary space partitioning (BSP)
+tree which allows very fast queries in 3D (Henry et al. 1980). The additional
+synergy is obtained by the flexible combination of both speed and complexity in
+the queries to the structural data. The combination of these factors makes p3d
+the optimal module to rapidly develop new and powerful bioinformatic tools that
+follow the Python philosophy of making the source code readable.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-chemistry/p3d/p3d-0.4.3.ebuild b/sci-chemistry/p3d/p3d-0.4.3.ebuild
new file mode 100644
index 000000000000..294acb075860
--- /dev/null
+++ b/sci-chemistry/p3d/p3d-0.4.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils versionator
+
+MY_P="${PN}-$(replace_version_separator 3 -)"
+GITHUB_ID="gb8b9a75"
+
+DESCRIPTION="Python module for structural bioinformatics"
+HOMEPAGE="http://p3d.fufezan.net/"
+SRC_URI="https://nodeload.github.com/fu/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+IUSE="examples"
+
+src_prepare() {
+ mv fu* ${P}
+ distutils_src_prepare
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r pdbs exampleScripts || die
+ fi
+}
diff --git a/sci-chemistry/p3d/p3d-9999.ebuild b/sci-chemistry/p3d/p3d-9999.ebuild
new file mode 100644
index 000000000000..e0f8087a0cc2
--- /dev/null
+++ b/sci-chemistry/p3d/p3d-9999.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=3
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit git-2 distutils versionator
+
+DESCRIPTION="Python module for structural bioinformatics"
+HOMEPAGE="http://p3d.fufezan.net/"
+SRC_URI=""
+EGIT_REPO_URI="git://github.com/fu/p3d.git"
+
+SLOT="0"
+KEYWORDS=""
+LICENSE="GPL-3"
+IUSE="examples"
+
+S="${WORKDIR}"/${PN}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/${PN}
+ doins -r pdbs exampleScripts || die
+ fi
+}