summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry/pdbmat')
-rw-r--r--sci-chemistry/pdbmat/pdbmat-3.89.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
index 89445471ef73..0119b3877d08 100644
--- a/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
+++ b/sci-chemistry/pdbmat/pdbmat-3.89.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=4
+EAPI=6
inherit cmake-utils fortran-2
@@ -19,11 +19,14 @@ S="${WORKDIR}"/Source_ENM2011
src_prepare() {
cp "${FILESDIR}"/CMakeLists.txt . || die
+
+ cmake-utils_src_prepare
}
src_configure() {
- mycmakeargs=(
- $(cmake-utils_use examples EXAMPLES)
+ local mycmakeargs=(
+ -DEXAMPLES=$(usex examples)
)
+
cmake-utils_src_configure
}