summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-electronics/Stage/Stage-9999.ebuild')
-rw-r--r--sci-electronics/Stage/Stage-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sci-electronics/Stage/Stage-9999.ebuild b/sci-electronics/Stage/Stage-9999.ebuild
new file mode 100644
index 000000000000..424c575679c9
--- /dev/null
+++ b/sci-electronics/Stage/Stage-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="https://github.com/rtv/Stage"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="https://github.com/rtv/Stage/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="The Stage Robot Simulator"
+HOMEPAGE="http://rtv.github.io/Stage/"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-libs/libltdl:0
+ virtual/jpeg:0
+ media-libs/libpng:0=
+ x11-libs/fltk
+ virtual/glu
+ virtual/opengl
+"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"