summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/grass/grass-8.2.1.ebuild')
-rw-r--r--sci-geosciences/grass/grass-8.2.1.ebuild4
1 files changed, 3 insertions, 1 deletions
diff --git a/sci-geosciences/grass/grass-8.2.1.ebuild b/sci-geosciences/grass/grass-8.2.1.ebuild
index 70d3a66f7e30..0b77a9524bf5 100644
--- a/sci-geosciences/grass/grass-8.2.1.ebuild
+++ b/sci-geosciences/grass/grass-8.2.1.ebuild
@@ -36,7 +36,7 @@ else
S="${WORKDIR}/${MY_P}"
fi
-IUSE="blas cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite threads tiff truetype X zstd"
+IUSE="blas bzip2 cxx fftw geos lapack las mysql netcdf nls odbc opencl opengl openmp pdal png postgres readline sqlite threads tiff truetype X zstd"
REQUIRED_USE="
${PYTHON_REQUIRED_USE}
opengl? ( X )"
@@ -60,6 +60,7 @@ RDEPEND="
virtual/cblas[eselect-ldso(+)]
virtual/blas[eselect-ldso(+)]
)
+ bzip2? ( app-arch/bzip2:= )
fftw? ( sci-libs/fftw:3.0= )
geos? ( sci-libs/geos:= )
lapack? ( virtual/lapack[eselect-ldso(+)] )
@@ -188,6 +189,7 @@ src_configure() {
$(use_with threads pthread)
$(use_with openmp)
$(use_with opencl)
+ $(use_with bzip2 bzlib)
$(use_with pdal pdal "${EPREFIX}"/usr/bin/pdal-config)
$(use_with las liblas "${EPREFIX}"/usr/bin/liblas-config)
$(use_with netcdf netcdf "${EPREFIX}"/usr/bin/nc-config)