summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-geosciences/qgis/files/qgis-9999-featuresummary.patch')
-rw-r--r--sci-geosciences/qgis/files/qgis-9999-featuresummary.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/sci-geosciences/qgis/files/qgis-9999-featuresummary.patch b/sci-geosciences/qgis/files/qgis-9999-featuresummary.patch
new file mode 100644
index 000000000000..8fa7ab0e8428
--- /dev/null
+++ b/sci-geosciences/qgis/files/qgis-9999-featuresummary.patch
@@ -0,0 +1,31 @@
+From 0744b51784b779eab4bb2e78ed084d31258b5b4d Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <andreas.sturmlechner@gmail.com>
+Date: Sun, 28 Apr 2019 00:10:21 +0200
+Subject: [PATCH] cmake: Use FeatureSummary
+
+---
+ CMakeLists.txt | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4dff8ea0f4..4626042ca4 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -71,6 +71,8 @@ IF(NOT MSVC)
+ endif(USE_CCACHE)
+ endif()
+
++include(FeatureSummary)
++
+ # in generated makefiles use relative paths so the project dir is moveable
+ # Note commented out since it cause problems but it would be nice to resolve these and enable
+ #
+@@ -937,3 +939,5 @@ ENDIF (WITH_CORE)
+ if (UNIX AND NOT APPLE)
+ add_subdirectory(linux)
+ endif()
++
++FEATURE_SUMMARY(WHAT ALL FATAL_ON_MISSING_REQUIRED_PACKAGES)
+--
+2.21.0
+