summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/cdf/files/cdf-3.2-soname.patch')
-rw-r--r--sci-libs/cdf/files/cdf-3.2-soname.patch22
1 files changed, 22 insertions, 0 deletions
diff --git a/sci-libs/cdf/files/cdf-3.2-soname.patch b/sci-libs/cdf/files/cdf-3.2-soname.patch
new file mode 100644
index 000000000000..e4f28617faca
--- /dev/null
+++ b/sci-libs/cdf/files/cdf-3.2-soname.patch
@@ -0,0 +1,22 @@
+--- src/lib/Makefile.orig 2007-12-03 17:47:58.476149933 +0000
++++ src/lib/Makefile 2007-12-03 17:50:34.353032850 +0000
+@@ -94,7 +94,7 @@
+
+ shared.yes: libcdf.$(SHAREDEXT)
+
+-libcdf.so \
++libcdf.$(SHAREDEXT) \
+ libcdf.dylib \
+ libcdf.sl: $(OBJs)
+ @if [ -f $@ ] ; then rm $@ ; else $(NULL) ; fi
+@@ -102,8 +102,8 @@
+ echo $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS); \
+ $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS); \
+ else \
+- echo $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS); \
+- $(LD) $(LDFLAGS) -o $@ $(OBJs) $(SYSLIBS); \
++ echo $(LD) $(LDFLAGS) -Wl,-soname,libcdf.$(SHAREDEXT) -o $@ $(OBJs) $(SYSLIBS); \
++ $(LD) $(LDFLAGS) -Wl,-soname,libcdf.$(SHAREDEXT) -o $@ $(OBJs) $(SYSLIBS); \
+ fi
+
+ libcdf.o: $(OBJs)