summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/coinhsl')
-rw-r--r--sci-libs/coinhsl/Manifest1
-rw-r--r--sci-libs/coinhsl/coinhsl-2014.01.10.ebuild33
-rw-r--r--sci-libs/coinhsl/metadata.xml12
3 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/coinhsl/Manifest b/sci-libs/coinhsl/Manifest
new file mode 100644
index 000000000000..e4a3eadc3394
--- /dev/null
+++ b/sci-libs/coinhsl/Manifest
@@ -0,0 +1 @@
+DIST coinhsl-2014.01.10.tar.gz 906586 SHA256 7c2be60a3913b406904c66ee83acdbd0709f229b652c4e39ee5d0876f6b2e907 SHA512 fe71b07c4fc11a8a7a40a115457588b91aa4481726e523502d92d6604c5fda13cffcc4620ada64b9332cb3502f8bfbc4ee856125cd5fd987cccf49bae5d46711 WHIRLPOOL 7b59a9d2d532cb494d12485529cf13d14d48a354a622c3d8d2252f46f0aaeb5e60d4ee17f8d11e3e4717cf81d056709b4b03a2dcebbfbf60ea264b55303e4834
diff --git a/sci-libs/coinhsl/coinhsl-2014.01.10.ebuild b/sci-libs/coinhsl/coinhsl-2014.01.10.ebuild
new file mode 100644
index 000000000000..32fb559aad0e
--- /dev/null
+++ b/sci-libs/coinhsl/coinhsl-2014.01.10.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+AUTOTOOLS_IN_SOURCE_BUILD=yes
+FORTRAN_STANDARD="77 90"
+
+inherit autotools-utils fortran-2 toolchain-funcs
+
+DESCRIPTION="HSL mathematical software library for IPOPT"
+HOMEPAGE="http://www.hsl.rl.ac.uk/ipopt"
+SRC_URI="${P}.tar.gz"
+
+LICENSE="HSL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND="
+ sci-libs/metis
+ virtual/blas"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+RESTRICT="mirror fetch"
+
+src_configure() {
+ export LIBS="$($(tc-getPKG_CONFIG) --libs metis blas lapack)"
+ autotools-utils_src_configure
+ MAKEOPTS+=" -j1"
+}
diff --git a/sci-libs/coinhsl/metadata.xml b/sci-libs/coinhsl/metadata.xml
new file mode 100644
index 000000000000..2dc94508a9bf
--- /dev/null
+++ b/sci-libs/coinhsl/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ HSL (formerly the Harwell Subroutine Library) is a collection of
+ state-of-the-art packages for large-scale scientific computation
+ such as the solution of sparse linear systems of equations and
+ sparse eigenvalue problems. This package is specific as a plugin for
+ Ipopt.
+</longdescription>
+</pkgmetadata>