summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/io_lib/io_lib-1.14.7.ebuild')
-rw-r--r--sci-libs/io_lib/io_lib-1.14.7.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sci-libs/io_lib/io_lib-1.14.7.ebuild b/sci-libs/io_lib/io_lib-1.14.7.ebuild
new file mode 100644
index 000000000000..b05d7955fe92
--- /dev/null
+++ b/sci-libs/io_lib/io_lib-1.14.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit eutils
+
+DESCRIPTION="General purpose trace and experiment file reading/writing interface"
+HOMEPAGE="http://staden.sourceforge.net/"
+SRC_URI="mirror://sourceforge/staden/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+DEPEND="
+ net-misc/curl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+# tests fails and might need sci-biology/staden from
+# the science overlay
+
+RESTRICT="test"
+
+src_configure() {
+ econf $(use static-libs static)
+}
+
+src_install() {
+ default
+ use static-libs || prune_libtool_files
+ dodoc docs/{Hash_File_Format,ZTR_format}
+}