summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-libs/libtifiles2/libtifiles2-1.1.7.ebuild')
-rw-r--r--sci-libs/libtifiles2/libtifiles2-1.1.7.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/sci-libs/libtifiles2/libtifiles2-1.1.7.ebuild b/sci-libs/libtifiles2/libtifiles2-1.1.7.ebuild
new file mode 100644
index 000000000000..93059a32adcc
--- /dev/null
+++ b/sci-libs/libtifiles2/libtifiles2-1.1.7.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Library for TI calculator files"
+HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
+SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc nls static-libs"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ >=sci-libs/libticables2-1.3.3
+ >=sci-libs/libticonv-1.1.3
+ nls? ( virtual/libintl )"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf --disable-rpath \
+ $(use_enable static-libs static) \
+ $(use_enable nls)
+}
+
+src_install() {
+ use doc && HTML_DOCS=( docs/html/. )
+ default
+ find "${D}" -name '*.la' -delete || die
+}