summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/arb/files/arb-2.18.0-build_type.patch')
-rw-r--r--sci-mathematics/arb/files/arb-2.18.0-build_type.patch21
1 files changed, 21 insertions, 0 deletions
diff --git a/sci-mathematics/arb/files/arb-2.18.0-build_type.patch b/sci-mathematics/arb/files/arb-2.18.0-build_type.patch
new file mode 100644
index 000000000000..1db7d5f2df42
--- /dev/null
+++ b/sci-mathematics/arb/files/arb-2.18.0-build_type.patch
@@ -0,0 +1,21 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index ec806fe..4101c09 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -19,11 +19,11 @@ endif ()
+ set (BUILD_SHARED_LIBS yes CACHE BOOL "Build shared library or not")
+ set (BUILD_TESTING no CACHE BOOL "Build tests or not")
+
+-if (NOT (CMAKE_BUILD_TYPE STREQUAL "Debug" OR
+- CMAKE_BUILD_TYPE STREQUAL "Release"))
+- message("${CMAKE_BUILD_TYPE}")
+- message(FATAL_ERROR "CMAKE_BUILD_TYPE must be one of: Debug, Release (current value: '${CMAKE_BUILD_TYPE}')")
+-endif ()
++# if (NOT (CMAKE_BUILD_TYPE STREQUAL "Debug" OR
++# CMAKE_BUILD_TYPE STREQUAL "Release"))
++# message("${CMAKE_BUILD_TYPE}")
++# message(FATAL_ERROR "CMAKE_BUILD_TYPE must be one of: Debug, Release (current value: '${CMAKE_BUILD_TYPE}')")
++# endif ()
+
+ if ("${CMAKE_SIZEOF_VOID_P}" STREQUAL "8")
+ set (PLATFORM "x64")