summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/gsl-shell/files/gsl-shell-2.3.0-gdt-cflags.patch')
-rw-r--r--sci-mathematics/gsl-shell/files/gsl-shell-2.3.0-gdt-cflags.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/sci-mathematics/gsl-shell/files/gsl-shell-2.3.0-gdt-cflags.patch b/sci-mathematics/gsl-shell/files/gsl-shell-2.3.0-gdt-cflags.patch
new file mode 100644
index 000000000000..388fa003f0ff
--- /dev/null
+++ b/sci-mathematics/gsl-shell/files/gsl-shell-2.3.0-gdt-cflags.patch
@@ -0,0 +1,20 @@
+--- a/gdt/Makefile
++++ b/gdt/Makefile
+@@ -27,7 +27,7 @@ include $(GSH_BASE_DIR)/makedefs
+
+ INCLUDES += -I$(GSH_BASE_DIR)
+
+-CFLAGS += -std=c99
++GDT_CFLAGS = $(CFLAGS) -std=c99
+
+ GDT_SRC_FILES = char_buffer.c gdt_index.c gdt_table.c
+ GDT_OBJ_FILES := $(GDT_SRC_FILES:%.c=%.o)
+@@ -36,7 +36,7 @@ DEP_FILES := $(GDT_SRC_FILES:%.c=.deps/%.P)
+
+ DEPS_MAGIC := $(shell mkdir .deps > /dev/null 2>&1 || :)
+
+-COMPILE = $(CC) $(CFLAGS) $(LUA_CFLAGS) $(DEFS) $(INCLUDES)
++COMPILE = $(CC) $(GDT_CFLAGS) $(LUA_CFLAGS) $(DEFS) $(INCLUDES)
+
+ TARGETS = libgdt.a
+