summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/octave-epstk')
-rw-r--r--sci-mathematics/octave-epstk/Manifest4
-rw-r--r--sci-mathematics/octave-epstk/metadata.xml11
-rw-r--r--sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild40
-rw-r--r--sci-mathematics/octave-epstk/octave-epstk-2.4.ebuild40
4 files changed, 95 insertions, 0 deletions
diff --git a/sci-mathematics/octave-epstk/Manifest b/sci-mathematics/octave-epstk/Manifest
new file mode 100644
index 000000000000..d12ebe6b416d
--- /dev/null
+++ b/sci-mathematics/octave-epstk/Manifest
@@ -0,0 +1,4 @@
+DIST octave-epstk_2.3-2.debian.tar.gz 10079 RMD160 31473407f9748448dde539530f5bc91a53a5d8c6 SHA1 e01a2db83b89addfa1b68b99a966966bdaad14b8 SHA256 fbfdfb15a1df78395553c8c014c20743312ae84e404697336c8df16ecec6d20d
+DIST octave-epstk_2.3.orig.tar.bz2 1401307 RMD160 0c7c2b9e23210e98c487d1087aea665d58f622b2 SHA1 8b31619b5455e2a8080f2016a556b0a7a7f40397 SHA256 c496e1eb1fc97cd01cbe2004664c5ffae271f542cecc63d7f596b062400aae61
+DIST octave-epstk_2.4-1.debian.tar.gz 10905 RMD160 c44a544b9006dd6ef169e6bd686c85581be88aaa SHA1 fd388638db491818e7fe7a08cf872048e58cef27 SHA256 20d961434b58ad3ace9af2ecd199fe458903146126ceaea905ea0173246b1973
+DIST octave-epstk_2.4.orig.tar.bz2 1072111 RMD160 b6862ad9047ea77d1c052b399333c76a7550d02d SHA1 d2d60b903eed3a348ad79014da5e6fba6d52e830 SHA256 8de20e9529a0f3503d50bb31867c00c2564d5e6e570daf5786c51592ec673551
diff --git a/sci-mathematics/octave-epstk/metadata.xml b/sci-mathematics/octave-epstk/metadata.xml
new file mode 100644
index 000000000000..1e986b205ff0
--- /dev/null
+++ b/sci-mathematics/octave-epstk/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci-mathematics</herd>
+<longdescription lang='en'>
+ The epsTk package provides, via a set of functions for octave, a
+ toolkit to create powerful encapsulated postscript (.eps) graphs. Most 2D
+ scientific graphics functions are written. The generated .eps-files are very
+ small and can be imported into other documents without loss of quality.
+</longdescription>
+</pkgmetadata>
diff --git a/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild b/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild
new file mode 100644
index 000000000000..835585e9cb0a
--- /dev/null
+++ b/sci-mathematics/octave-epstk/octave-epstk-2.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils
+
+DEB_PR=2
+DESCRIPTION="Graphical output functions for Matlab and Octave"
+HOMEPAGE="http://www.epstk.de/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.debian.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="sci-mathematics/octave
+ app-text/ghostscript-gpl"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ local p
+ cd eps*
+ for p in $(cat "${WORKDIR}"/debian/patches/series); do
+ epatch "${WORKDIR}"/debian/patches/${p}
+ done
+}
+
+src_install () {
+ insinto /usr/share/octave/site/m/${PN}
+ doins eps*/m/* || die
+ use doc && dohtml -r eps*/doc/*
+ insinto /etc
+ doins debian/epstk.conf || die
+ dodoc debian/README.Debian debian/changelog
+}
diff --git a/sci-mathematics/octave-epstk/octave-epstk-2.4.ebuild b/sci-mathematics/octave-epstk/octave-epstk-2.4.ebuild
new file mode 100644
index 000000000000..fe34729072ae
--- /dev/null
+++ b/sci-mathematics/octave-epstk/octave-epstk-2.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils
+
+DEB_PR=1
+DESCRIPTION="Graphical output functions for Matlab and Octave"
+HOMEPAGE="http://www.epstk.de/"
+SRC_URI="mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}.orig.tar.bz2
+ mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV}-${DEB_PR}.debian.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+SLOT="0"
+IUSE="doc"
+
+RDEPEND="sci-mathematics/octave
+ app-text/ghostscript-gpl"
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ local p
+ cd eps*
+ for p in $(cat "${WORKDIR}"/debian/patches/series); do
+ epatch "${WORKDIR}"/debian/patches/${p}
+ done
+}
+
+src_install () {
+ insinto /usr/share/octave/site/m/${PN}
+ doins eps*/m/*
+ use doc && dohtml -r eps*/doc/*
+ insinto /etc
+ doins debian/epstk.conf
+ dodoc debian/README.Debian debian/changelog
+}