summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/octave/octave-3.6.4-r1.ebuild')
-rw-r--r--sci-mathematics/octave/octave-3.6.4-r1.ebuild17
1 files changed, 7 insertions, 10 deletions
diff --git a/sci-mathematics/octave/octave-3.6.4-r1.ebuild b/sci-mathematics/octave/octave-3.6.4-r1.ebuild
index e698a8ca08ad..3aeefddb4a7c 100644
--- a/sci-mathematics/octave/octave-3.6.4-r1.ebuild
+++ b/sci-mathematics/octave/octave-3.6.4-r1.ebuild
@@ -17,6 +17,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
SLOT="0/${PV}"
IUSE="curl doc fftw +glpk gnuplot graphicsmagick hdf5 +imagemagick opengl postscript
+qhull +qrupdate readline +sparse static-libs X zlib"
+REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
RDEPEND="
@@ -29,10 +30,8 @@ RDEPEND="
glpk? ( sci-mathematics/glpk )
gnuplot? ( sci-visualization/gnuplot )
hdf5? ( sci-libs/hdf5 )
- imagemagick? (
- graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
- !graphicsmagick? ( media-gfx/imagemagick:=[cxx] )
- )
+ graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
+ imagemagick? ( media-gfx/imagemagick:=[cxx] )
opengl? (
media-libs/freetype:2
media-libs/fontconfig
@@ -114,12 +113,10 @@ src_configure() {
$(use_with X x)
$(use_with zlib z)
)
- if use imagemagick; then
- if has_version media-gfx/graphicsmagick[cxx]; then
- myeconfargs+=( "--with-magick=GraphicsMagick" )
- else
- myeconfargs+=( "--with-magick=ImageMagick" )
- fi
+ if use graphicsmagick; then
+ myeconfargs+=( "--with-magick=GraphicsMagick" )
+ elif use imagemagick; then
+ myeconfargs+=( "--with-magick=ImageMagick" )
else
myeconfargs+=( "--without-magick" )
fi