summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics/octave/octave-4.0.1.ebuild')
-rw-r--r--sci-mathematics/octave/octave-4.0.1.ebuild13
1 files changed, 2 insertions, 11 deletions
diff --git a/sci-mathematics/octave/octave-4.0.1.ebuild b/sci-mathematics/octave/octave-4.0.1.ebuild
index a90d8000ce2a..d84666836f3b 100644
--- a/sci-mathematics/octave/octave-4.0.1.ebuild
+++ b/sci-mathematics/octave/octave-4.0.1.ebuild
@@ -15,7 +15,7 @@ HOMEPAGE="http://www.octave.org/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
SLOT="0/${PV}"
-IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java jit opengl
+IUSE="curl doc fftw +glpk gnuplot graphicsmagick gui hdf5 +imagemagick java opengl
postscript +qhull +qrupdate readline +sparse static-libs X zlib"
REQUIRED_USE="?? ( graphicsmagick imagemagick )"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
@@ -35,9 +35,6 @@ RDEPEND="
graphicsmagick? ( media-gfx/graphicsmagick:=[cxx] )
imagemagick? ( media-gfx/imagemagick:=[cxx] )
java? ( >=virtual/jre-1.6.0:* )
- jit? (
- >=sys-devel/autoconf-archive-2015.02.04
- >=sys-devel/llvm-3.3:0= <sys-devel/llvm-3.6:0= )
opengl? (
media-libs/freetype:2=
media-libs/fontconfig:1.0=
@@ -89,12 +86,6 @@ src_prepare() {
use gui && append-ldflags -Wl,-rpath,"${EPREFIX}/usr/$(get_libdir)/qt4"
fi
- # Octave fails to build with LLVM 3.5 https://savannah.gnu.org/bugs/?41061
- use jit && \
- has_version ">=sys-devel/llvm-3.5" && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5.patch && \
- epatch "${FILESDIR}"/${PN}-4.0.0-llvm-3.5-gnulib-hg.patch
-
# Fix bug 501756
sed -i \
-e 's@A-Za-z0-9@[:alnum:]@g' \
@@ -116,10 +107,10 @@ src_configure() {
--with-blas="$($(tc-getPKG_CONFIG) --libs blas)"
--with-lapack="$($(tc-getPKG_CONFIG) --libs lapack)"
--disable-64
+ --disable-jit
$(use_enable doc docs)
$(use_enable java)
$(use_enable gui)
- $(use_enable jit)
$(use_enable readline)
$(use_with curl)
$(use_with fftw fftw3)