summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/maxima/maxima-5.43.2.ebuild10
1 files changed, 10 insertions, 0 deletions
diff --git a/sci-mathematics/maxima/maxima-5.43.2.ebuild b/sci-mathematics/maxima/maxima-5.43.2.ebuild
index 7c68f0a0e322..88f7e81d580d 100644
--- a/sci-mathematics/maxima/maxima-5.43.2.ebuild
+++ b/sci-mathematics/maxima/maxima-5.43.2.ebuild
@@ -129,9 +129,19 @@ src_configure() {
if [ ${CONF} = . ]; then
CONF=${LISPS[${n}]}
fi
+ if [[ ${CONF} == ccl ]]; then
+ # 64-bit version of clozurecl is enabled
+ # by --enable-ccl64, not by --enable-ccl.
+ # bug #665364
+ use amd64 && CONF=ccl64
+ fi
CONFS="${CONFS} --enable-${CONF}"
done
+ # Gentoo calls 'ccl' both 32-bit and 64-bit version of clozurecl.
+ # bug #665364
+ CONFS="${CONFS} --with-ccl64=ccl"
+
# enable existing translated doc
if use nls; then
for lang in ${LANGS}; do