summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-physics/root')
-rw-r--r--sci-physics/root/files/proofd.confd12
-rw-r--r--sci-physics/root/files/proofd.initd25
-rw-r--r--sci-physics/root/files/root-6.14.00-http.patch28
-rw-r--r--sci-physics/root/files/rootd.confd8
-rw-r--r--sci-physics/root/files/rootd.initd27
5 files changed, 0 insertions, 100 deletions
diff --git a/sci-physics/root/files/proofd.confd b/sci-physics/root/files/proofd.confd
deleted file mode 100644
index 81720a7eb335..000000000000
--- a/sci-physics/root/files/proofd.confd
+++ /dev/null
@@ -1,12 +0,0 @@
-# conf.d file for proof daemon
-#
-# Please refer to the proofd(1) man(1) page for more information on
-# command line parameters.
-#
-PROOFD_OPTS=
-
-# Specify your base of your PROOF directory here. If left blank, it
-# will use the system default (e.g., /usr/share/root/proof).
-# Note, however, that ROOT recommends that this directory is shared (via
-# NFS or similar) among all the nodes of the cluster.
-PROOF_DIR=
diff --git a/sci-physics/root/files/proofd.initd b/sci-physics/root/files/proofd.initd
deleted file mode 100644
index ee865133cb25..000000000000
--- a/sci-physics/root/files/proofd.initd
+++ /dev/null
@@ -1,25 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need root-file-server
- use logger
-}
-
-start() {
- ebegin "Starting parallel ROOT facility server"
- start-stop-daemon --start --quiet \
- --pidfile /var/run/proofd.pid \
- --exec /usr/bin/proofd -- ${PROOFD_OPTS} ${PROOF_DIR}
- pidof /usr/bin/proofd > /var/run/proofd.pid
- eend $?
-}
-
-stop() {
- ebegin "Stopping parallel ROOT facility server"
- start-stop-daemon --stop --quiet \
- --pidfile /var/run/proofd.pid \
- --exec /usr/bin/proofd
- eend $?
-}
diff --git a/sci-physics/root/files/root-6.14.00-http.patch b/sci-physics/root/files/root-6.14.00-http.patch
deleted file mode 100644
index 04ec4bea567b..000000000000
--- a/sci-physics/root/files/root-6.14.00-http.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From bed1568548d7a47785d8fe24ec7a9ce5799040ff Mon Sep 17 00:00:00 2001
-From: Guilherme Amadio <amadio@cern.ch>
-Date: Wed, 27 Jun 2018 15:08:07 +0200
-Subject: [PATCH] Do not exclude etc/http directory from installation
-
-This was an unintended side-effect of a previous commit:
-9b4d0d8dccbd48d21b0f7c79b6eaf94428f691b1.
----
- CMakeLists.txt | 3 +--
- 1 file changed, 1 insertion(+), 2 deletions(-)
-
-diff --git a/CMakeLists.txt b/CMakeLists.txt
-index 4c760d0fdb..a3a0f59925 100644
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -426,8 +426,7 @@ if(NOT CMAKE_SOURCE_DIR STREQUAL CMAKE_INSTALL_PREFIX)
- PATTERN "rootd.xinetd" EXCLUDE
- PATTERN "proofd.xinetd" EXCLUDE
- PATTERN "root.mimes" EXCLUDE
-- PATTERN "cmake" EXCLUDE
-- PATTERN "http" EXCLUDE )
-+ PATTERN "cmake" EXCLUDE )
- install(DIRECTORY fonts/ DESTINATION ${CMAKE_INSTALL_FONTDIR})
- install(DIRECTORY icons/ DESTINATION ${CMAKE_INSTALL_ICONDIR})
- install(DIRECTORY macros/ DESTINATION ${CMAKE_INSTALL_MACRODIR})
---
-2.18.0
-
diff --git a/sci-physics/root/files/rootd.confd b/sci-physics/root/files/rootd.confd
deleted file mode 100644
index 7516b8c9b6dd..000000000000
--- a/sci-physics/root/files/rootd.confd
+++ /dev/null
@@ -1,8 +0,0 @@
-# conf.d file for root daemon
-
-# User to run as (default is `rootd')
-ROOTD_USER="rootd"
-
-# Please refer to the rootd(1) man(1) page for more information on
-# command line parameters.
-ROOTD_OPTS=""
diff --git a/sci-physics/root/files/rootd.initd b/sci-physics/root/files/rootd.initd
deleted file mode 100644
index f808259c3670..000000000000
--- a/sci-physics/root/files/rootd.initd
+++ /dev/null
@@ -1,27 +0,0 @@
-#!/sbin/openrc-run
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-depend() {
- need net
- use logger
- provide root-file-server
-}
-
-start() {
- ebegin "Starting ROOT file server"
- pid=$(start-stop-daemon --start --quiet --user ${ROOTD_USER} \
- --pidfile /var/run/rootd.pid \
- --exec /usr/bin/rootd -- ${ROOTD_OPTS})
- retval=$?
- echo ${ROOTD_PID} > /var/run/rootd.pid
- eend ${retval}
-}
-
-stop() {
- ebegin "Stopping ROOT file server"
- start-stop-daemon --stop --quiet \
- --pidfile /var/run/rootd.pid \
- --exec /usr/bin/rootd
- eend $?
-}