summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-visualization/opendx/opendx-4.4.4-r5.ebuild')
-rw-r--r--sci-visualization/opendx/opendx-4.4.4-r5.ebuild42
1 files changed, 19 insertions, 23 deletions
diff --git a/sci-visualization/opendx/opendx-4.4.4-r5.ebuild b/sci-visualization/opendx/opendx-4.4.4-r5.ebuild
index 5c02453d732d..6cff41fe1a44 100644
--- a/sci-visualization/opendx/opendx-4.4.4-r5.ebuild
+++ b/sci-visualization/opendx/opendx-4.4.4-r5.ebuild
@@ -1,21 +1,19 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=6
+EAPI=4
MYP=dx-${PV}
-
-inherit autotools eutils flag-o-matic
+inherit eutils flag-o-matic autotools multilib
DESCRIPTION="3D data visualization tool"
HOMEPAGE="http://www.opendx.org/"
-SRC_URI="http://opendx.sdsc.edu/source/${MYP}.tar.gz
- https://dev.gentoo.org/~soap/distfiles/${PN}-4.4.4_p20160917-fix-c++14.patch.bz2"
+SRC_URI="http://opendx.sdsc.edu/source/${MYP}.tar.gz"
LICENSE="IBM"
SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+KEYWORDS="amd64 ppc x86 ~amd64-linux ~x86-linux"
IUSE="hdf cdf netcdf tiff imagemagick szip smp"
RDEPEND="x11-libs/libXmu
@@ -29,29 +27,26 @@ RDEPEND="x11-libs/libXmu
hdf? ( sci-libs/hdf )
cdf? ( sci-libs/cdf )
netcdf? ( sci-libs/netcdf )
- tiff? ( media-libs/tiff:0 )
- imagemagick? ( media-gfx/imagemagick )"
+ tiff? ( media-libs/tiff )
+ imagemagick? ( virtual/imagemagick-tools )"
DEPEND="${RDEPEND}
virtual/pkgconfig"
S="${WORKDIR}/${MYP}"
-PATCHES=(
- "${FILESDIR}/${PN}-4.3.2-sys.h.patch"
- "${FILESDIR}/${P}-installpaths.patch"
- "${FILESDIR}/${P}-xdg.patch"
- "${FILESDIR}/${P}-gcc43.patch"
- "${FILESDIR}/${P}-dx-errno.patch"
- "${FILESDIR}/${P}-libtool.patch"
- "${FILESDIR}/${P}-concurrent-make-fix.patch"
- "${FILESDIR}/${P}-open.patch"
- "${FILESDIR}/${P}-szip.patch"
- "${FILESDIR}/${P}-null.patch"
- "${WORKDIR}/${PN}-4.4.4_p20160917-fix-c++14.patch"
-)
src_prepare() {
- default
+ epatch "${FILESDIR}/${PN}-4.3.2-sys.h.patch"
+ epatch "${FILESDIR}/${P}-installpaths.patch"
+ epatch "${FILESDIR}/${P}-xdg.patch"
+ epatch "${FILESDIR}/${P}-gcc43.patch"
+ epatch "${FILESDIR}/${P}-dx-errno.patch"
+ epatch "${FILESDIR}/${P}-libtool.patch"
+ epatch "${FILESDIR}/${P}-concurrent-make-fix.patch"
+ epatch "${FILESDIR}/${P}-open.patch"
+ epatch "${FILESDIR}/${P}-szip.patch"
+ epatch "${FILESDIR}/${P}-null.patch"
+ epatch "${FILESDIR}/${P}-magick.patch"
eautoreconf
}
@@ -69,6 +64,7 @@ src_configure() {
# javadx is currently broken. we may try to fix it someday.
econf \
+ --libdir="${EPREFIX}"/usr/$(get_libdir) \
--with-x \
--without-javadx \
$(use_with szip szlib) \