summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/accountsservice')
-rw-r--r--sys-apps/accountsservice/Manifest1
-rw-r--r--sys-apps/accountsservice/accountsservice-0.6.42.ebuild54
-rw-r--r--sys-apps/accountsservice/files/accountsservice-0.6.35-gentoo-system-users.patch4
3 files changed, 57 insertions, 2 deletions
diff --git a/sys-apps/accountsservice/Manifest b/sys-apps/accountsservice/Manifest
index 06217c400948..bbbaa62e0d2e 100644
--- a/sys-apps/accountsservice/Manifest
+++ b/sys-apps/accountsservice/Manifest
@@ -1 +1,2 @@
DIST accountsservice-0.6.40.tar.xz 367772 SHA256 f04f756600cbab558671658ab8e77212de2a000c07bc0469e7b51541871fcb2b SHA512 da12a97ca9a2eb69d978fd3b5f46e8dd2e2f3e6f57db027e0b8c8c583c715d45f105c9ddcd1a2a1c4a2f4bfce672431e601a7cd0f063b31675fd6f13b6cb4ef8 WHIRLPOOL 3a12f5e5e68f3b21ec1347a9e1677b8eee10818ced138e35a3b1f61d8814a6af5ad50aed352a0fcbec819d8271c46c8db2e93ea0c7ccbbb5672f0f7e7e4786be
+DIST accountsservice-0.6.42.tar.xz 380500 SHA256 e56494c2f18627900b57234e5628923cc16a37bf8fd16b06c46118d6ae9c007e SHA512 b31d77b88793a8264d32963a98ad446537292a134a3f80fabb4e2ce30f796e5f3066d02a27515c993133fa493b511a6abba6ff1a7827b5a54ea6a4f62a7b6fc9 WHIRLPOOL 2da1b5037f2306d93471db8ae792145abded9f33e5014f5ad748bb0d988757a4c5e53e5e64ef69752b6e80041af09a87512b95b1b955cfc75b379d7cec40d496
diff --git a/sys-apps/accountsservice/accountsservice-0.6.42.ebuild b/sys-apps/accountsservice/accountsservice-0.6.42.ebuild
new file mode 100644
index 000000000000..3e4d0ee21025
--- /dev/null
+++ b/sys-apps/accountsservice/accountsservice-0.6.42.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit gnome2 systemd
+
+DESCRIPTION="D-Bus interfaces for querying and manipulating user account information"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/AccountsService/"
+SRC_URI="https://www.freedesktop.org/software/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc +introspection selinux systemd"
+
+CDEPEND="
+ >=dev-libs/glib-2.37.3:2
+ sys-auth/polkit
+ introspection? ( >=dev-libs/gobject-introspection-0.9.12:= )
+ systemd? ( >=sys-apps/systemd-186:0= )
+ !systemd? ( sys-auth/consolekit )
+"
+DEPEND="${CDEPEND}
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/xmlto )
+"
+RDEPEND="${CDEPEND}
+ selinux? ( sec-policy/selinux-accountsd )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.6.35-gentoo-system-users.patch"
+)
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ --disable-more-warnings \
+ --localstatedir="${EPREFIX}"/var \
+ --enable-admin-group="wheel" \
+ --with-systemdsystemunitdir="$(systemd_get_systemunitdir)" \
+ $(use_enable doc docbook-docs) \
+ $(use_enable introspection) \
+ $(use_enable systemd)
+}
diff --git a/sys-apps/accountsservice/files/accountsservice-0.6.35-gentoo-system-users.patch b/sys-apps/accountsservice/files/accountsservice-0.6.35-gentoo-system-users.patch
index 9868e26ea39c..39ebf42ea6ac 100644
--- a/sys-apps/accountsservice/files/accountsservice-0.6.35-gentoo-system-users.patch
+++ b/sys-apps/accountsservice/files/accountsservice-0.6.35-gentoo-system-users.patch
@@ -1,5 +1,5 @@
---- src/user-classify.c.old 2013-12-04 20:29:48.944454769 +0100
-+++ src/user-classify.c 2013-12-04 20:32:59.728283477 +0100
+--- a/src/user-classify.c.old 2013-12-04 20:29:48.944454769 +0100
++++ b/src/user-classify.c 2013-12-04 20:32:59.728283477 +0100
@@ -55,6 +55,48 @@
"at",
"gdm",