summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/ack/ack-3.4.0.ebuild')
-rw-r--r--sys-apps/ack/ack-3.4.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-apps/ack/ack-3.4.0.ebuild b/sys-apps/ack/ack-3.4.0.ebuild
new file mode 100644
index 000000000000..0df2c490211b
--- /dev/null
+++ b/sys-apps/ack/ack-3.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=PETDANCE
+DIST_VERSION="v${PV}"
+inherit perl-module
+
+DESCRIPTION="ack is a tool like grep, optimized for programmers"
+HOMEPAGE="https://beyondgrep.com"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-perl/File-Next-1.180.0"
+DEPEND="${RDEPEND}
+ test? ( dev-perl/IO-Tty )"
+
+PATCHES=( "${FILESDIR}"/${PN}-3.3.0-gentoo.patch )
+
+src_test() {
+ # Tests fail when run in parallel and if dev-perl/IO-Tty is installed
+ # which enables interactive tests that need to read from stdin. If IO-Tty
+ # is not installed the related tests are skipped.
+ MAKEOPTS+=" -j1" perl-module_src_test
+}