summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/audio-entropyd/audio-entropyd-2.0.3.ebuild')
-rw-r--r--sys-apps/audio-entropyd/audio-entropyd-2.0.3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/sys-apps/audio-entropyd/audio-entropyd-2.0.3.ebuild b/sys-apps/audio-entropyd/audio-entropyd-2.0.3.ebuild
new file mode 100644
index 000000000000..1dfc1007e9a2
--- /dev/null
+++ b/sys-apps/audio-entropyd/audio-entropyd-2.0.3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Audio-entropyd generates entropy-data for the /dev/random device"
+HOMEPAGE="http://www.vanheusden.com/aed/"
+SRC_URI="http://www.vanheusden.com/aed/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-entropyd )
+ media-sound/alsa-utils
+ media-libs/alsa-lib"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.1-uclibc.patch" \
+ "${FILESDIR}/${PN}-2.0.1-ldflags.patch"
+ sed -i -e "s:^OPT_FLAGS=.*:OPT_FLAGS=${CFLAGS}:" \
+ -e "/^WARNFLAGS/s: -g::" Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dosbin audio-entropyd
+ dodoc README TODO
+ newinitd "${FILESDIR}/${PN}.init-2" ${PN}
+ newconfd "${FILESDIR}/${PN}.conf-2" ${PN}
+}