summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/clrngd/clrngd-1.0.3-r2.ebuild')
-rw-r--r--sys-apps/clrngd/clrngd-1.0.3-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-apps/clrngd/clrngd-1.0.3-r2.ebuild b/sys-apps/clrngd/clrngd-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..8f8098302781
--- /dev/null
+++ b/sys-apps/clrngd/clrngd-1.0.3-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Clock randomness gathering daemon"
+HOMEPAGE="http://echelon.pl/pubs/"
+SRC_URI="http://echelon.pl/pubs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0.3-implicit-func-declaration.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --bindir="${EPREFIX}"/usr/sbin
+}
+
+src_install() {
+ default
+
+ newinitd "${FILESDIR}"/${PN}-init.d-r2 ${PN}
+ newconfd "${FILESDIR}"/${PN}-conf.d ${PN}
+}