summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/clrngd/files')
-rw-r--r--sys-apps/clrngd/files/clrngd-1.0.3-implicit-func-declaration.patch27
-rw-r--r--sys-apps/clrngd/files/clrngd-init.d-r214
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-apps/clrngd/files/clrngd-1.0.3-implicit-func-declaration.patch b/sys-apps/clrngd/files/clrngd-1.0.3-implicit-func-declaration.patch
new file mode 100644
index 000000000000..075866ec8044
--- /dev/null
+++ b/sys-apps/clrngd/files/clrngd-1.0.3-implicit-func-declaration.patch
@@ -0,0 +1,27 @@
+--- a/clrngd.c
++++ b/clrngd.c
+@@ -14,6 +14,13 @@
+ #include <sys/time.h>
+ #include <stdio.h>
+ #include <string.h>
++
++#ifdef HAVE_STROPT_H
++#include <stropts.h>
++#else
++#include <sys/ioctl.h>
++#endif
++
+ #include <linux/types.h>
+ #include <linux/random.h>
+ #include <errno.h>
+--- a/configure.in
++++ b/configure.in
+@@ -18,7 +18,7 @@ dnl Checks for libraries.
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
+-AC_CHECK_HEADERS(unistd.h sys/param.h sys/time.h time.h sys/mkdev.h sys/sysmacros.h string.h memory.h fcntl.h dirent.h sys/ndir.h ndir.h alloca.h locale.h )
++AC_CHECK_HEADERS(unistd.h sys/param.h sys/time.h time.h sys/mkdev.h sys/sysmacros.h string.h memory.h fcntl.h dirent.h sys/ndir.h ndir.h alloca.h locale.h stropts.h)
+
+ jm_CHECK_TYPE_STRUCT_UTIMBUF
+ AC_HEADER_MAJOR
diff --git a/sys-apps/clrngd/files/clrngd-init.d-r2 b/sys-apps/clrngd/files/clrngd-init.d-r2
new file mode 100644
index 000000000000..5a7bc5be924d
--- /dev/null
+++ b/sys-apps/clrngd/files/clrngd-init.d-r2
@@ -0,0 +1,14 @@
+#!/sbin/openrc-run
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name='clrngd'
+command='/usr/sbin/clrngd'
+command_args="${clrngd_opts:-${DELAYTIME}}"
+description="Clock entropy for RNG"
+
+depend() {
+ after random
+ before net
+ provide entropy
+}