summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-apps/edid-decode/edid-decode-0_pre20230131.ebuild')
-rw-r--r--sys-apps/edid-decode/edid-decode-0_pre20230131.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/sys-apps/edid-decode/edid-decode-0_pre20230131.ebuild b/sys-apps/edid-decode/edid-decode-0_pre20230131.ebuild
new file mode 100644
index 000000000000..ab504c4b4a5a
--- /dev/null
+++ b/sys-apps/edid-decode/edid-decode-0_pre20230131.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+EGIT_COMMIT="915b0ce5329f417d2c3f84ddab3d443dd0e01b61"
+MY_P="${PN}-${EGIT_COMMIT}"
+
+DESCRIPTION="Decode EDID data in a human-readable format"
+HOMEPAGE="https://git.linuxtv.org/edid-decode.git/"
+SRC_URI="https://dev.gentoo.org/~conikost/distfiles/${P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+KEYWORDS="amd64 arm64 ~loong ppc64 ~riscv x86"
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples"
+
+src_compile() {
+ tc-export CXX
+ default
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+ einstalldocs
+
+ if use examples; then
+ insinto /usr/share/edid-decode/examples
+ doins data/*
+ fi
+}